Update to SmartThings Groovy Transition

I have many virtual devices created by the smartapp virtual devices creator.
Will this all be automatically migrated to a local version as well?

So far the only official word on this is that they are looking into it. :disappointed_relieved:

Several community members have come up with ways to create virtual devices for the new architecture. If you want to go ahead and create some for yourself, see the following for the alternatives:

FAQ: Creating Virtual Devices with the new architecture (Without the IDE) (2023)

1 Like

I think you should be OK because those devices are based on stock handlers intended for production use, just like the other devices being migrated

If you had been using the ‘simulated’ family of devices I’d be less optimistic as they were intended as test devices, though you wouldn’t really know that if you just picked them out in the IDE.

1 Like

I’ve slowly been losing devices to my network. Train wreck in slow motion. First was the Smartthings wifi Smart Plug and now the Amzn wifi smart plug. Expected some would need different connections. But not Smartthings branded devices or Samsung OCF supported devices.
The ST plugs are still shown, but offline. The Amzn wifi plugs are just gone.

What am I missing?

Do they have edge drivers? If not, then maybe still a chance one will be developed. If they do, then take a look at the source of the edge driver.

Sadly, not that I can find. I will have to replace the units. Just hope no more ‘migrations’ are headed my way. Hopefully they zombie back one day.
Thanks

The Amazon Wi-Fi smart plug never had a direct smartthings integration that I know of. You might have been activating it through an Amazon routine that relied on a virtual device that is no longer functional. If so, that virtual device could be replaced with one that does work with the new architecture.

Can you post a screenshot of a routine that used the Amazon smart plug?

2 Likes

My whole house has been acting flakey since the firmware update.
I especially notice using our phones as presence hardly works at all now .so the alarm often does not notice we left or arrived.
Any thoughts .
Todd

2 Likes

Both our iOS and Android phones have been completely unreliable for presence in the ST app. If you have an Alexa device, here is a link to how I’ve set up presence for the two people in our house.

Another option now that IFTTT and ST integration has returned would be to do a similar setup as I described in the link, but using IFTTT for geo-fencing and having it turn on/off a virtual presence sensor in ST.

1 Like

JD, Happily the darned things woke up last evening and this.
I’m going to activate the 3 day rule. If broken for 3 days, begin to search for answer, otherwise wait for it to fix itself.
Didn’t want your question to go unanswered, the routines are only on the Amzn side and simple. Echo setup required ST for the completion, but the routine remained in Echo.
I will continue to look for undated drivers for the bricked the Samsung plugs.
Thanks

1 Like

I have two hubs each in different locations.
I noticed on one hub one of the automations now has a check mark on it and upon opening it says running locally.
Very nice. No idea how that hub and that automation were deemed worthy and none of the others.

If you had existing automations that predated specific local requirements, they won’t automatically get the house checkmark icon when they do match local requirements. You have to save the routine again (change the name text as something has to be updated) to have it reset the icon.

1 Like

Hi

  1. None of this hubs automations have been changed in at least 6 weeks.
  2. On the second hub I created several new automations but none have the check.

Todd

If you have routines that access devices across hubs, they will always require the cloud.

1 Like

You may want to edit your post and remove your phone number :slight_smile:

Be careful when replying by email that contains a signature file

4 Likes

I have a Samsung multipurpose sensor that went offline when Samsung converted it to an Edge driver. I suppose the only thing I can do now is to remove it and add it back? I’ll need to put a placeholder in any routines where it appears so they don’t get deleted. I hope I can peel it off the fridge so I can get it close enough to my hub so that it can be found…

Try adding the sensor in situ first.
For some reason, I have found re-adding (Ikea GU10s in my case) much easier this time than when they were first added.

1 Like

You can try disabling “Secure ZigBee mode” temporarily and see if it comes back (click your hub->settings).

1 Like

Secure zigbee mode was already off. Darn. I’ll try connecting it in situ and see what happens. Thanks.

My device migration is seeing glacial progress.
Before Christmas I believe I had 28 devices on dth.
About a week ago it dropped to 26.
Anyone seeing much better progress?
A good chunk of my devices are IKEA bulbs and motion sensors and buttons, but not all.