Unable to see any SmartApps on iPhone

ON the new SmartThings app I have been unable to see any of my SmartApps for quite some time now. My wife can see them on her Galaxy phone so I know its not just a matter of certain apps being in different areas now. For example, I have WebCore installed as a SmartApp that shows up on my wifes phone but not mine. Even if I add a new SmartApp it still shows up blank on my device.
I waited to post this since I was anticipating getting a new phone. The issue is persisting even though I am on a new phone (iPhone 11 Pro)

First thing that comes to mind is that you have some sort of sync issue. You should definitely contact ST support.

Tagging @Brad_ST

I did contact support a couple months ago. It was a dead end unfortunately. I have been monitoring these boards as well hoping I would see something but I havent seen anyone with this same issue.
I dont have a few custom SmartApps that I added through the SmartThings IDE. I thought maybe there was some issue with those but that does not explain why it shows up fine in my wifes phone.
When I got my new iPhone I did restore from an iCloud backup so maybe it pulled some of the bad program cache? Anyone know how I can completely blow everything away and start fresh? I have tried a simple uninstall and re-install before.

Did support ever get back in touch? Or did the 1st level of support not have an answer for you?

If you have uninstalled/reinstalled the app, that is basically the best option. You see all your devices? You don’t have a second location? Click menu and at the top, you should see your Home location with a pull-down. Click to see if there might be a second but doubtful that is your issue.

But contact support and open a new ticket and ask for a higher level of support. If you are in a region where calling is available, that is your better option for contacting them and speaking to support directly instead of email.

Everything looks properly synced. Do you have a support ticket # I can reference? Does your wife’s account own the location by chance?

Looks like the ticket number is 1028495
It was all through e-mail.

My account is the owner account.

Thanks. Can you try loading the list of SmartApps again? There was an incompletely installed SmartApp that I removed. I’ve seen that cause issues in the past in the new app.

Unfortunately I still get that same screen of the guy floating on a cloud. :frowning:

Aha! I just blew away all of my Pentair Pool Controller items from Bsileo on Github and it works now. Pool season is done, I guess I will re-visit this next year :slight_smile:

Doh. I missed that. It’s the spaces in the icon url:

If you change those three icon urls, you should be good to go. For example:
http://cdn.device-icons.smartthings.com/Health & Wellness/health2-icn.png


I’m not sure if the dev is actively reviewing PRs but I made one anyway: