Unable to enable Smartthings skill in Alexa

Just purchased a Smartthings Hub v3. When attempting to enable the Alexa skill for SmartThings from my iPhone, I use the Alexa app to enable SmartThings, log in, select my location, tap authorize, and receive “We were unable to link SmartThings at this time”. Some points to consider:

  • Other skills for other hardware (e.g nest, ring) are enabled in Alexa.
  • The Smartthings app itself works as I can lock/unlock my Schlage connect deadbolts.

to the best of my knowledge, everything is updated to latest software versions. I feel like I’m forgetting to do something simple/obvious.

Any ideas?
thank you!

What region are you in?

US. Florida. My iphone / google wifi / alexa are not using any VPN. The geoIP location would be florida.

see if it does the same thing using a browser on a pc. https://alexa.amazon.com

thanks! that did it… “SmartThings has been successfully linked.”
I had no idea I could even interact with alexa on a browser like that.

Thanks to all!


App is limited to the PC’s which are sold via Lenovo, HP, Aces but you can install the app in any PC. Below are the steps by which you can follow to download Alexa app for windows .

To download Alexa app, Firstly, download Amazon Alexa Win32 app version from the dropbox

  • Important – the link is not an official link.
  • Scan the downloaded file and check for antivirus. After that run the downloaded file inside the ZIP archive and then accept “User Account Control Prompt”. Now, follow the Prompt and get app downloaded for your Windows PC.**
  • Now, go to the Alexa Setting and then enable the Launch app on sing into your PC if you want Alexa to be launched when you log in to the Windows Account.
  • Note – You require to install Microsoft Visual C++ 2015 on your system to use Alexa. If it is not installed in your system you not need to worry as setup will automatically install it. ALEXA App for Windows 10** is ready to us.
    For more info visit http://www.download-alexa.com/
1 Like

I am having the same problem of not being able to authorize Smart Things with Alexa. When I get to the web page that has the gives me the option to authorize the skill it has a drop down menu for location and asks me to select one, but when you click the menu it doesn’t provide any locations. It will not allow you to click authorize without choosing a location. I have tried this through the app on Android phone and the above link for the PC, both do the same thing.

Please help :frowning:
Thank you

Kind of the same issue but when I try to link smartthings to Alex’s it says incorrect username/password. But it’s what I’m logging in to smart things with. Even changed the password Incase I was incorrect.

Has been working fine for a few years, but recently moved and rebuilt my smart home. ST and Alexa weren’t talking so I unlinked. Now I can’t get them linked.

Edit: Using the classic app…

Maybe log out of and back into Alexa/Amazon first?