Unable to delete device...still


#1

I’m trying to remove a device but it won’t. When I try in the app or IDE I get the following error in the logs:

ed1a5c2b-2ec9-4696-95ba-980d7ab3bd10  3:30:20 PM MST: error java.lang.reflect.UndeclaredThrowableException
ed1a5c2b-2ec9-4696-95ba-980d7ab3bd10  3:30:20 PM MST: trace uninstalled()

I’ve tried waiting it out, thinking it was just general ST-ness as I was able to remove two other of these identical devices but this third one won’t delete. I can update everything about this device, the name, device type, etc but deleting errors out.

@slagle This has nothing to do with the maintenance. This has been ongoing for more than a week now (that’s what I meant when I said I tried to wait it out above) and even after you guys have sent the all clear, I’m still seeing this same issue.

Any suggestions on how I can delete this device? Is this something support is going to have to do?


(Tim Slagle) #2

Please submit a support ticket so we can have an engineer look at it if necessary.


#3

Thanks, I’ll submit a support ticket.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #4

We’re seeing this with many SmartApp uninstall attempts too. I thought is was related to failures of the underlying schedule / unschedule engine (since SmartTiles gets the error for runIn() and, of course, uninstall has to wipe all schedules implicitly.


(Anthony) #5

I am also having this issue trying to remove a couple of virtual presence devices that I am no longer using…

Unable to remove from App, unable to delete from IDE.
Able to update name, device type, etc, etc.
No SmartApps installed with these devices.

Was there ever a resolution to this?


#6

Yeah, I had to submit a support ticket, they were able to remove it.