[UK] Nest Thermostat Device Type

OK, I’ve just tested mine again and now I’ve got the same issues.

Let me have a play and will come back

Can you try this code please.


I got it working after hitting refresh a number of times. Keep an eye in the logging pane for stuff that looks likes its working


Looks good to me, I have tested it an it works now.


1 Like


Is it possible to have the main display show the points as well. I noticed ST is showing temperature at 21 but on the nest it’s actually 20.5


Hmmm, strange. Does it ever show a .5 degree for the temperature? As you can see on my screenshot from Android, it’s showing 18.5 degrees

In iOS I find the main display only shows whole degrees (rounded up), even though the devices list shows half degrees. For example, next to ‘LR Nest’ in the devices list I have ‘21.5’, but if I go into the device it displays ‘22’.

Ugh, this is another crappy SmartThings development issue I guess. Just like half the features in the developer documents don’t work on Android.

I’m not entirely sure what to do here. The below code is what stores the target temperature (which does show 0.5 increments, and the temperature that the house is currently at (which uses the same maths and works on Android)

def temperature = 0.5*(Math.round(data.shared.current_temperature/0.5))    
def targetTemperature = 0.5*(Math.round(data.shared.target_temperature/0.5))

Will this work for the UK Generation 3 Nest Thermostat?

In theory it should, however I don’t have a 3rd gen to test with

Thanks, I made it to step 5 but I can’t see anywhere to add a serial?

I can see an Edit Button next to a Delete button when I click on the device but no serial field.

It should look like this:

Cheers mate, re-read the instructions and I chose Nest Thermostat instead of Nest. It seems setup ok now.


Hello, I’ve just installed a 3rd Gen Nest and followed the instructions to add to my SmartThings hub. It shows up under ‘things’ on my iOS app but when I tap on Nest in the list the app instantly crashes. I get a flash of the Nest controls (albeit a messed up version of it) before it crashes out.

Under the Device List, it seems to be communicating with the hub okay. It’s displaying values next to the temperature, humidity etc. I just can’t get the iOS app to work.

Any ideas?

Same here unfortunately, I saw a couple of other threads mentioning this in passing - perhaps its a “thing”. Sad times.

Do you mean that it no longer works? Surely one of the clever coders on here can fix that?

I wouldn’t necessarily go that far, but it seems that the iOS app currently quits when you try to view the Nest device.

As a followup here, we’ve managed to get this going under a separate thread.
Please see …

Awesome. I think I understand what’s happened - setPresence has been changed to setNestPresence in the code. I’ll just do a find/replace on my code and this should fix the issue for iOS users.

One thing I’ve noticed that has stopped working (for me at least) is the polling. I can’t figure out why…

Thanks… although my code was set to setPresence already but still doesn’t work. Is yours now working and not crashing out when you try to access it via SmartThings?

The code I’m using is

Is this the version you’re using too?

Sorry, my reply might have been a bit misleading. I haven’t actually got around to change my devicetype on github yet!