Token Scope Error

I can’t select Token scope in smartthings API.

Welcome to the SmartThings Community, @Cyan!

Where are you seeing this error, can you share the link, please?

@nayelyz SmartThings. Add a little smartness to your things.
is the link!

oh, that’s strange I didn’t recognize the page without the scope list.
I can open it correctly, so, it might be something on your side or account…

Can you clear the browser’s cache and try again, please?
If it is still happening, can you open the developer tools in the browser to see if you get an error there?


I’m having the same issue as well. I’ve tried clearing the cache but no luck.
The only things in the developer console are some warnings from i18next about missing translation keys

Welcome to the SmartThings Community, @Y0lk!

Can you share the following info so I can create a report for the engineering team, please?

  1. Screenshot of the issue (the page without the scope list). The one with the errors you shared is useful.
  2. Confirm if the email you use here in the forum is the same as in your ST account. If not, please send it over a DM.
  3. Enable support access to your account
  1. Go to the SmartThings Web (
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.


  1. Here’s a screenshot. Looks basically the same as the screenshot from the other person
  2. The email I use is the same
  3. I’ve just enabled support access

Hi, @Y0lk

Thanks for the info.
Following up, the engineering team mentioned if you could share the timeframe or timestamp when the error happened. For example “08:20 CST”

Also, does this happen every time you enter this page even if you refresh it?

Yes, this happens every time. I have not been able to create a new access token because of this issue.
I just tried again to get you a time stamp: “11:21 EST”

Hi @Y0lk @Cyan , I’m Alejandro from the dev support team

We generated a report about your problem, and the engineering team told us that they deployed some changes to correct it. So, please, Can you try to create a token and tell us if the problem is still happening?


I just tried again and I still have the same problem. I’ve tried clearing my cache again as well but it didn’t change anything. I still have the same issue where I don’t see any scopes.

Hi @Y0lk @Cyan

The team found the error, they mentioned it will solved later on, there’s no ETA yet.

However, they provided this workaround for you to be able to create a PAT while the issue is being solved. You can set your locale to en-US using sensors for Chrome


Thanks for the temporary solution! I can confirm that overriding the locale worked.

1 Like