Thermostat - Mains voltage 2-wire battery operated, SmartThings compatible (UK) (see post #8 for Secure SRT edge driver)

Like the title says I’m looking for a central heating thermostat that is battery operated (no mains anywhere nearby) will switch mains voltage and is SmartThings compatible. Circuitry is similar to attached, needs to be a drop in replacement for the attached.

ETA: UK based, SmartThings hub v2

The only things I can find either:
a) won’t switch 240v
b) need a receiver
c) aren’t SmartThings compatible
d) aren’t battery operated
e) need more than two wires



What country are you in? The device selection does vary.

Also, do you have a Smartthings/Aeotec hub, and if so, which model?

Sorry, UK. SmartThings Hub v2

1 Like

I found this but I does not say if the contacts are rated for 240v.

In the US boiler control circuit would typically be 24 v AC.

1 Like

I think it might work, I’ve ordered it and will feed back once received, thanks.

1 Like

I use a Secure SRT323 thermostat (Z-Wave) which works well for me.
It switches 220v to a zone valve, which in turn controls the boiler.
I think they can be purchased new from specialised suppliers but I bought mine on eBay.
Initially I used a community Groovy handler and then wrote my own custom Edge driver for it.
Happy to share the driver via channel invitation.

1 Like

Ah, that’s very useful, thanks. I have a Secure SRT323 but I bought it “reconditioned” and could never get it to work. I was never sure if it was me or the unit that was faulty:

Forgive my ignorance but what’s a “channel invitation”?

In the recent past Smartthings was based on Groovy (computer language).
I used a custom Groovy device handler by aonghusmor to control my SRT323.
However, Smartthings have moved away from Groovy over the past year; shutting them down completely in the last few weeks. The new thing is ‘Smartthings Edge’ and it is good.

If you were to successfully pair your SRT323 to Smartthings today, it would likely appear as a ‘Z-Wave Thing’ which would not have much functionality. This is the default behavior for a Z-Wave device that does not find a suitable driver on your Smartthings hub.

Do you know how to put your SRT323 into pairing mode?
If not, the first thing you need to do is ‘exclude’ the SRT323 from your Smartthings.
You might say ‘but its not on my Smartthings’ but ‘exclude’ is the step you need to do before you can start pairing.
1). Put your SRT323 in ‘pairing’/‘exclusion’ mode (I can help with this if you don’t know how)
2). In your Smartthings App (mine is on Android; iPhone may be subtly different),
a). click on your hub,
b). then click on the ‘three dots’ menu,
c). then click on ‘Settings’
d). then click on ‘Z-Wave utilities’
e). finally click on ‘Z-Wave exclusion’
It should report something like ‘1 devices excluded’.
3). Now take your SRT323 out of ‘pairing’/‘exclusion’ mode.

Now, on to pairing. Ideally your SRT323 should be near your Smartthings hub (not always easy)
1). In the Smartthings App
a). use the ‘+’ to ‘Add device’;
b). then click on ‘Scan for nearby devices’
2). Put your SRT323 in ‘pairing’/‘exclusion’ mode
Hopefully the Smartthings App will find your SRT323;
It may take a few goes.
3). Now take your SRT323 out of ‘pairing’/‘exclusion’ mode.

You are now over half way there.
2). In your Smartthings App,
a). click on the SRT323 (it might be called something else),
b). then click on the ‘three dots’ menu,
c). then click on ‘Driver’
You will probably see something saying it is a ‘Z-Wave Thing’.

When you get this far, reply to this post and I will have a ‘channel invitation’ ready for you to proceed with the final step.

p.s., I also have a V2 hub (great device) and some spares.

Good luck,

1 Like

Here is an invitation to subscribe to my Secure SRT Channel (when you are ready):

Id 1b962061-058e-42fd-9ee0-8175a351ae84
Name Willboyes
Profile Id 61a79569-e8fd-4a4d-9b9c-a4a55ccdd15e
Accept URL

These are the driver versions:

Secure SRT Thermostat 2ef60174-383d-42ca-ad5d-895f42952efd 2022-09-10T14:39:26.688728594 2022-12-03T18:24:35.934170128Z 2022-12-03T18:24:35.934170211Z
Secure SRT321 Thermostat 12ab013a-546b-47c2-a9b6-0a043f1ce8b4 2023-03-04T17:03:08.265842616 2022-12-03T18:25:10.520466183Z 2023-07-12T18:33:19.169676739Z

1 Like

Thank you so much. It took two goes to get the exclusion working but after that it all went smoothly.
I take it I was supposed to install both drivers, I did “Secure SRT Thermostat” then “Secure SRT321 Thermostat”. Does it take time for a temp adjustment I make in the SmartThings app to reflect in the thermostat itself?

Hi @andykn,
The Secure SRT321 is a different (wireless) thermostat. You just need ‘Secure SRT’.
Yes, it does take some time for an App change to reflect on the SRT323.
This is because the SRT323 is a battery device and only wakes up periodically to speak to the Smartthings hub.
The wake-up interval can be configured to be more often; but this will impact the battery life.
I think you can change the interval via the ‘three dots’->Settings menu.
If not, there is a special ‘configuration’ driver called ‘Z-Wave Device Config Mc’ that you can select temporarily to configure devices, before switching back to your main driver.
I do most of my thermostat set-point changes via automations. I time these automations to fire a few minutes before the thermostat is due to wake up
(you can figure this out by doing an App change and watching the thermostat until the set-point actually changes).
A great feature of custom Edge drivers (over custom Groovy ones) is that the execute on the Smartthings hub (as opposed to the Smartthings cloud) meaning your automations will run even if your internet is down (important for heating etc.)
Cheers, Aidan

1 Like

OK, I hit “Uninstall” on “Secure SRT321 Thermostat”, just leaves the “Secure SRT Thermostat”, which is reflected in the SmartThings console “Driver” for the device.
I found the wake up interval, thanks, it’s set at 10 minutes but if I change the “Heating Temperature” in the app it seems to take up to an hour to propagate to the thermostat.
Thanks again for all your help.

1 Like

Hmmm, 1 hour is not very good (great for battery life; but not practical).
Test a setpoint change again today (first at random, then a minute or two after the thermostat reflects the change). If it is still about an hour on the second change then I recommend you (temporarily) install the ‘Z-Wave Device Config Mc’ driver I mentioned above (you should find an invitation URL somewhere in this forum).
‘Z-Wave Device Config Mc’ will allow you to interrogate details of your device including the exact fingerprint. There are some different minor versions that may have a different order of parameters. As well as interrogating the device fingerprint, you can also request the current parameters and even set new parameter values (before switching back to the SRT driver.

1 Like

The first time I moved the temp in the SmartThings app it seemed to change almost immediately on the stat, then i changed it again and it took an hour. I’ve been fiddling with the setting a bit more and it seems a bit random. I think I’ll change the reporting interval to 9 (minutes) and have another play tomorrow night.

Hi @andykn ,
We will get there but we need some diagnostics.
Just checking, in the SRT323 ‘…->Settings’ the number you enter in minutes (not seconds).
This is the diagnostic driver you will need to install:

Once you subscribe to the ‘Mariano Shared Beta Driver’, install ‘Z-Wave Device Config Mc’
On your Smartthings App, open the SRT323 device and click ‘… → Driver’ and 'Select ‘Select different driver’.
When you exit the SRT323, and open it again, it will look nothing like a Thermostat.
Here is one view (in this case it’s my SIR321 (did not want to mess up my Thermostats):

You can view different information via ‘…->Settings’ and you can even write parameters.
A little bit of trial and error is required. When you are done, switch back to the SRT323 driver.
Cheers, Aidan

Hi @andykn
Any joy with your SRT323 wakeup interval?
Reading the manuals, the default should be 15 minutes.
Have you done an Exclusion and factory reset before Including on your Smartthings hub?
Cheers, Aidan

I’ve just tried it a few times and it does seem to be responding more quickly now, probably within the 9 minutes currently set. I suppose I should make a note of timings.

I think it’s working OK, thanks again for your help.
Time set, temp set, time applied
21.28 27 21.36
21.37 20 21.45
21.46 24 21.54
21.54 22 22.04

Hi @andykn
Am glad it is all working out.