Temperature readings are not accurate on 2 different devices


(qqqqq) #1

Has anyone else had an issue of getting accurate temperature readings? I have the Aeon multi sensor and the Smartsense multisensor and they are both displaying temperatures but they seem to be off by about 6 degrees which is disappointing especially for the Aeon multi sensor since that is the main purpose for purchase.

I’ve seen some posts stating that this is a known issue and is being worked on but haven’t seen any updates or follow-ups from ST on this subject.


(Carlos Perez) #2

Smartsense multisensor also seems to be not to accurate also. You can set offsets for each sensors if you know the - + difference for each


(Convinced ST will never be unbroken…) #3

They are all off with respect to each other, at least every one that I have tried… What I do is calibrate them all to my thermostat.


(Edward Pope) #4

Yep, that is what I did as well. After confirming that the Thermostat was accurate. Mine had to be adjusted one by one. I know that being a hardware guy that there are some variations. But, I have been surprised at the amount of variation no matter the manufacturer.