Temp Sensor Not Showing in Alexa

Hey guys,

I have a Tuya Zigbee temp sensor thats not showing in Alexa. Its set up as a SmartSense Temp/Humidity Sensor.

Any ideas?


  1. Do you have your Smart Life app linked to the Alexa app?
  2. Have you tried logging out of the Alexa app and logging back in?

I do not believe Alexa will show any ST sensors other than Motion and Contact sensors.

The only temperature sensor that I have ever seen in Alexa is one that was part of an Actual Echo device.

I haven’t researched this particular subject in probably over a year, so things may have changed since then.

I hadn’t really noticed that. But now that you mention it, my leak sensors (they are also temp sensors) do not show up in the Alexa app.

I have the Echo Show and they show up directly in the Alexa app because of the hub

Just to clarify - Do you have Zigbee temperature sensors paired directly with the Echo Show’s built-in Zigbee hub?

mmm, ok.

I was kinda sold SmartThings hub on that I could add all this stuff and have these awesomely powerful animations. But im finding it increasingly limited even just compared to Alexa.

I have to do some difficult flashing to get my Sonoffs working (mostly because it means taking them all back out of the walls) the magic home LED strips can only be done by the same thing.

It seems like its only good for senors and now thats letting me down as well. @ $120AUD (because everyone just loves to rip us off) this seems to be a bit to expensive just to use a couple of motion sensors.

Is this platform kinda dying? It just kinda seems like nothing new is being added, where things like Hubitat are supporting Magic Home LED strips natively.

I don’t know, I just brought this thing. so would very happy to be wrong.

Yes, sorry if that wasn’t clear.

Looks like ill have to delete them and re add them back to the Show to control the AC. Shame (I’m using Broadlink RM Pros to control IR AC units)

:wink: Hubitat has been my primary hub for over 2 years now. It was created by a group of former ST users who wanted local processing versus ST’s increased direction toward cloud processing. The two platform have much in common, so I still frequent the ST community as my ST_Anything Arduino integration is supported on both platforms.

Yeah, but it appears that Hubitat does not support the Ikea stuff that ST does or the Xiaomi sensors…

Anyway, so back to the topic lol, sorry.

Only motion sensors flow up to Alexa, even though Alexa does support temp sensors?

Does anyone know the reason, or if this will change?


Just throwing this out there. I have temp sensors not “showing” in the Alexa app, but if I ask Alexa what’s the temp of said sensor, she responds. She’ll even average multiple sensors.

This, unfortunately, doesn’t work with every temp reporting device such as the SmartThings Button.

I used this:

From my experience Alexa reads my thermostat temperatures as well as my Ecobee remote sensors but not just regular temp sensors. However, you can assign any device that has temp to the Virtual Thermostat (VT) and then have that VT discovered by Alexa!

I created a Virtual Switch just to satisfy the requirement of a switch (outlet) but is not really needed for Alexa.

Works great!

1 Like

So im super new to Smartthings,

Ive added the DTH and the smart app.

So I go to my device in myDH and I change the current temp sensor to a Virtual Thermostat Device.

I then go to the smart app and try to configure it and get an error in the new app. old app just churns.

What am I doing wrong?

And thanks for your help, I really appreciate it :slight_smile:

Seems like you are trying to change a physical device’s (temp sensor) DTH to a virtual device DTH. You should just assign the physical device to the Virtual Thermostat in the VT’s settings.

Ok, it did change and start showing up in Alexa. But its not something I can use to trigger a routine in the Alexa app.

So I can ask for the temp, but cant do anything with it

Can you confirm this is the same for you?

Correct. Alexa cannot trigger routines based on temperature.

Thanks mate!

Ill just have to re-add the device directly to Alexa so that I can :slight_smile: