Sunrise and Sunset times are way off for my location

Lately, my Sunrise/Sunset tines are way off. I have searched this issue, tried some of the suggestions of moving the geo-location to a very different place and then changing it back, and tried creating new smart lighting automations. Nothing has worked.

These times are way off (by more than an hour), and that is my correct timezone and location. Anyone have any ideas to try? I have stuff turning on and off way before they are suppose to.

1 Like

IDE is in the process of being shut down. That sunset/sunrise info has been deprecated and is no longer used. They stopped updating that info some time ago.

I apologize, I’m really out of the loop on this. What do you mean it is being shutdown? What’s the replacement? What do I use to drive my automations?

And CLI which isn’t mentioned in the thread above:

1 Like

While I appreciate your response (I really do), do you have any idea how over-our-head your reply is for most of the users of this assine platform?

Look, I just want my lights to come on at Sunset, that’s all. Worked perfect for years, now, not so much. I have the smart lighting automation setup for this and again, it worked for a long time. So what do I need to do to get it to work again? Why do I have to do all this complex stuff, why can’t the new platform handle the smart lighting automation that I already had? Are you telling me that Samsung can’t transition a simple “turn on light at sunset” automation to their new system?

I must be missing something. Can anyone walked me through how to recreate my light turning on at sunset?


I have seen a few users reporting issues with sunrise/sunset recently but I do not remember seeing if anyone resolved it. Do you use Routines/Scenes or Smart Lighting? If Smart Lighting, is it Lighting with upper case L or lighting with lower case l? Upper case indicates it is the old groovy version while lower case l indicates the new smart lighting plugin using the new architecture.

If it is the older version, you may want to try moving the rule over to the newer version or using Rotines. But again, that is if you use smart lighting,


Smart lighting, small l. Is there any other way to check when it thinks Sunrise and Sunset is other than in ide?

I currently use Smart lighting to fire a scene that controls multiple lights.

I’ll have to let others respond on finding the sunset/sunrise times. I think I saw someone had mentioned CLI but I may be wrong on that.

one thought… try a Routine instead and see how it plays out.

Supposedly things that run in the cloud using sunrise/sunset do not get an updated time for sunrise/sunset (they are static with the time they were implemented) Apparently, Smart lighting executes in the cloud. If you rewrite these as routines rather than use Smart lighting they should execute locally and update correctly.

Or… you could install Aplicaciones Virtuales Mc from Mariano’s channel and use the expanded sunrise/sunset capabilities offered by that.

Just as a point of reference, I use Routines for all my light on/off controls that use sunset/sunrise and have had no issues.

I’ve used Smart Lighting and now Smart lighting to trigger outdoor lights on at sunset for about 4 years. Other than an occasional glitch around daylight savings time, I’ve not had any issues.

Smart lighting automatons will run locally if everything in the automation can be run locally. Scenes are not eligible to run locally. You might want to try a test automation that uses a device or two in place of the scene.

Smart Lighting and its replacement Smart lighting run locally if the devices in a given routine can run locally. This was one of the advantage of the original Smart Lighting.

1 Like

Thanks everyone for your replies. Just wanted to come back and confirm that setting up these Sunset and Sunrise automations under Routines has solved the issue.

Thanks again.


Our of curiosity

  1. Are you still triggering a scene or did you list out the devices to change?
  2. Do you have the little house icon next to your Routine name indicating local execution?

Yes, I’m still triggering Scenes. I don’t see a house icon, looks like this:

Ok. Was just curious. Scenes are not able to run locally.


Hm… I see I commented on that thread last June. Had no recollection of that, but I’m old and forget things.

All I can say is that my Scenes, which all involve only stock DTHs and Edge devices, are ineligible to run locally. Routines that directly operate the same devices as are in the scene do run locally.

Maybe when migration of my last dozen devices is complete, I’ll revisit the Routines that reference them.

just had the issue today. converted to Smart lighting from routine just now. hopefully fixed it.

Better to go to Routines :slight_smile: