Strange Hue Problem


#1

On my Hue bridge I have several GE Link bulbs. Other than most of these GE bulbs, when view via the Hue app, always have the"!" symbol besides them indicating “this bulb may be unreachable”, they have been working fine without incident via the ST and Hue app as well as a python interface. Today, one of these bulbs started acting up.

This particular GE bulb will not respond to any on/off/dim command however, all apps show the status change. In otherwords, if I change the state of the LED via the ST app, the hue app reflects this change almost immediately. Likewise, if I send an on/off/dim command via a python script almost immediately both apps reflect this change. Problem is, the actual bulb does nothing.

Anyone know of a fix for this kind of problem?? If a reset is required, how do I do this when it is connected to a hue bridge? Remove, reset and re-add??


(Joe) #2

Not sure if this is related but since yesterday out of nowhere my hue bulbs and ge link bulbs won’t respond through smartthings at all. I unlinked them and the re added them and they worked for a few hours and then back to unresponsive.


(Bobby) #3

Does it work via hue app?


(Joe) #4

Yes it works via the hue app right away. Sonos speakers work with their app as well. Seems to be smartthings specific. At this point it feels like I am just waiting for another company to come out with a better hub to jump ship. I have spent way too many hours and money just trying to get fancy lighting. Resorting to just using normal switches.


(Bobby) #5

Rerun Hue connect, they changed the hue lux handler AGAIN…mine all are working…

@bamarayne s favorite topic!


#6

I’m a novice on most of this stuff. I followed these directions from Jared at support and it fixed my Hue problem.

Go to My Home in your SmartThings app
Go to the ‘Things’ tab
Find your Hue Bridge in your list of things, and tap on it
On this page, tap the gear icon on the upper right
Tap ‘Remove’. No worries, your bulbs will remain within SmartThings along with all of your automations!
Now, you’ll want to re-discover the bridge. Tap the Menu Menu and tap 'SmartApps’
Find 'Hue (Connect) in the list and tap on it.
Tap on where it says ‘Hue Bridge’ towards the bottom
On the next page your Hue Bridge should be discovered. Select it just like when you first connected it, and hit ‘Done’


(Convinced ST will never be unbroken…) #7

Pretty much. I have only had it happen of couple of times, usually after a power failure… And who knows how many times the power was cycled on and off.

As for the ‘!’, I pretty much see these on about half of the Links I have on my bridge. I have reset them previosly, but they eventually return to that state.

Interestingly, the last 5 I’ve reset since the latest Philips update have not returned to that state and it has been quite a number of days. So maybe they have addressed the issue.


#8

So how exactly do you reset them when they are connected to the Hue bridge? I assume they must be removed from the bridge, reset (on/off X 5) then re-added to the bridge??


(Convinced ST will never be unbroken…) #9

Yeah… Trash them from the Hue app, do the turn on/off every 3 seconds until they reset, and then run ‘connect new lights’.


(Bobby) #10

I really don’t think you need to go through all of this. It’s got to be a problem between the APIs not with the mesh itself. I would try rebooting hubs, disconnecting APIs, etc. It doesn’t make sense (to me) to delete a functional bulb from the mesh, if you can control the bulbs with hue app…


#11

Re-read my original post… I can change the state via any app or other interface (i.e. python) and such change is reflected within all apps that have access to the bulb. However, the actual bulb does nothing…

SOLVED
I was just about to follow scottinpollock advise but thought I would try one more thing.
I unplugged the lamp containing the LED and moved it from the location its been since the beginning of time, right next to the Hue Bridge. Voila the bulb now responds to all my apps. I unplugged it and placed it back in its original location. Voila… It works and has been working ever since :slight_smile:


(Jason "The Enabler" as deemed so by @Smart) #12

Keep an eye on it. I’ve had GE link that was doing the exact same thing. I thought I had it solved the exact same way. It just dies again in a day or two.

My solution, as they do this I am putting them on the hue bridge. I’ve had no problems there so far.

That, and I’m replacing done of them with hue bulbs also…


(Joe) #13

Can’t get the hue bulbs to do anything. Tried to rerun hue connect and deleted the bridge. Same thing no response. I think I just have to delete the bulbs from smartthings and start over. Super annoying.

Update I deleted all hue bulbs and the hub from smartthings as well as the ge link bulb I was having issues with. Added the link bulb directly to my hue bridge and then readded all hue items to smartthings. Working at the moment. Smartthings is a bit of a dumpster fire lately.


#14

All my GE bulbs have been on a Hue bridge at least a year. No guarantees either way.
The White Philips Hue are actually cheaper than the GE LEDS and seem much more stable… Plans are to buy more of them and trash the GE in time…