Status Updates from Thing Shields, Broke?


(Todd Wackford) #1

Is anyone getting status updates or string messages coming from their Shields? It appears since a recent update I’ve lost this required functionality. I’ve got a support ticket in, but I wanted to know if I am the only one seeing this. If this is a system issue, I’m wondering why no one else has posted anything.


(Todd Wackford) #2

Thanks to the Urmanator it’s no longer broke.

+1 to the ST gang again!

Twack


(Csader) #3

@wackware, did you have to do anything to make it start working again?


(Todd Wackford) #4

Nope. I didn’t have to do anything. Dr Urman fixed it on the hub side. He’s sooooo amazing :cool:


(Andrew Urman) #5
Dr Urman fixed it on the hub side. He’s sooooo amazing :cool:

Flattery will get you everywhere


(Csader) #6

So @urman, is this something that we each have to beg you for individually?


(Andrew Urman) #7

@csader if you’re one of the ~8 people affected by the same issue @wackware was having, than yes. It would require opening a support ticket.


(Jlbg) #8

Is there any way to tell if a command is being sent from the app?

It’d be nice if when I pushed a button on the app, it temporarily turned grey, or blinked or SOMETHING. I can’t tell if the app isn’t registering the click, or if it is working. it doesn’t log anything either from what I can tell.

My thingsheild reports to the app almost instantly, but the app never seems to send a command to the shield (it was working now it isn’t). Did i break the code?


(Jlbg) #9

Hm. Looks like I was checking some statuses and setting smartthing.shieldSetLED on every loop.
This was preventing the messageCallout from being called correctly. When changed the code to only set status led on a status change, it started working.

file this one as a bug.