Started getting 403 error on Confirmation lifecycle when connecting Webhook SmartApp

Hi everyone!
I started getting 403 error code when trying to verify my webhook Smart App.
Performed steps:

  1. Created a project at Developer Workspace
  2. Press Verify App Registration button
  3. Got a CONFIRMATION Lifecycle event via WebHook
    {"lifecycle"=>"CONFIRMATION", "executionId"=>"83A0CE64D33F4D6CAFD84030B5111FFF-ER8N", "appId"=>"[FILTERED]", "locale"=>"en", "version"=>"0.1.0", "confirmationData"=>{"appId"=>"[FILTERED]", "confirmationUrl"=>"[FILTERED]&nonce=[FILTERED]"}, "settings"=>{}}
  4. Made a GET request on webhook provided URL

As a result I get 403 response with no body
I cannot understand what is the root cause of the problem, as it was correctly working earlier. Could you provide some help?

Yes, a couple of us noticed this recently and @nayelyz has reported it. I believe it is tied in to an issue the engineering team were already aware of.

I found that persistence could pay off. The only difference I noted between a 403 and a success five minutes later was that different IP addresses were used. As was getting handled by a pool of eight IP address it was tempting to think it was a matter of getting lucky with one that was working. I don’t expect it to be anywhere near as simple as that given the sheer scale and complexity of the global AWS platform but it was nice to pretend at the time.

The original thread was the following one. It takes a while to get to the 403 issue.


Hi, @sandra-nestor

Thank you for reaching out!
As Graham mentioned, this is already reported and I added your post to that ticket as well for the team’s awareness.
Once we get an update, we’ll share it with you too. :smiley:


Thank you, @orangebucket @nayelyz! I’ll keep an eye on the thread.
Also, could you tell me approximate timeframes when the issue is expected to be resolved?

Hi, @sandra-nestor
The team hasn’t provided an ETA about this. Is there any particular complication for you in this case?

Yes, I can’t verify my Webhook SmartApp, so I cannot create a new integration. This is a vital feature of our app. We need to have it fixed ASAP

Hi, @sandra-nestor
The engineering team released the fix a few minutes ago, please help us verify the confirmation works now.

@nayelyz Thank you! I’ve just tried to verify my app and it worked.

1 Like