ST Multi Sensor Problems

I’ve had a working ST multi-sensor setup on a door for ~3 weeks now, but it seems to have developed problems over the last day or two. Using the ST IDE to monitor (mainly from the “My Devices” logs), I’ve noticed the following:

  • Contact sensor not registering open/close events, no log entries (in “my devices”) for over 24 hours now

  • The 3-Axis & acceleration sensors doesn’t trigger upon events, and only sometimes updates due to polling or manual refresh (acceleration currently stuck in “active”)

  • Battery and temperature polling seems to work and updates “most” of the times when manually refreshed

  • The live logging doesn’t appear to show any events from the multi-sensor apart from manual refresh command, and battery updates in “low battery notifications”

I would understand that if the multi-sensor was completely broken or there’s a weak signal, then there wouldn’t be anything being registered with the hub.

However, since the hub is still receiving battery and temperature readings via polling and manual refresh, then… is it only partially broken??

that is some thing you would want to contact support over…

Yeah, too used to posting on forums and such like, keep forgetting I can contact official support! I’ve emailed them now, ta!

1 Like

I’m having the exact same issue since yesterday morning. I will also try to contact ST support.

1 Like

Out of interest, did you get your Mulitpurpose Sensors showing temps in Celsius? Mine are stuck in Fahrenheit, with no Device Option to change it. My IDE Home Location shows my temperature scale as Celsius but still no joy.

(And yes, both tablet and phone with ST apps are in Celsius too).

Folks, did support respond regarding this issue? I’m having similar problems.

Hi @Twisticles i have raised this with support via email as i am also affected by this - some sensors are showing in Celsius but the Multi Sensor is stuck in Fahrenheit :confused: rather than hijack this thread i will update here as i created a new dedicated thread for it: Temperature format - one showing C, another F

This one is a bit of a whack a mole game, especially because some (but not all) customers reported that it corrected itself. Send an email to with the email address for your account and screenshots of the devices reporting in Fahrenheit.

Right, an update. Contacted ST support and they sorted out some stuff behind the scenes but also suggested removing/re-adding to the Hub to correct the open/close sensor (which I’ve done).

After a week, it mostly works now…

  • open/close seems to be working as expected

  • motion triggers but can take up to an hour to revert back to “inactive”

  • hitting manual refresh can appear to trigger motion??

  • temp only seems to show up (and only sometimes) via a manual refresh…

@Twisticles, my multi sensor was stuck on Fahrenheit but corrected itself after a few days.

If you check in with with an approximate time when this is occurring, we can check to see if there is a delay in the motion sensor reports or just slow to refresh the mobile app.

I’ve compared with the IDE logs and the mobile app, and they do seem to tally with each other. Anyway, I have just checked in with, thanks for the reminder!

Does anyone know if you can turn down the accelerometer sensitivity as its active nearly all the time. Also my routine doesn’t seem to work with it unless the app is open, as I have set it up so if the accelerometer is active then send push but that doesn’t work unless app is open

It’s kind if like the IT crowd… Can you log out and back in to see you get push notifications when the app isn’t open? Also, ensure they are not turned off on the phone OS level. If you’re still having issues, shoot a note to support