St hub v2 zigbee direct connect device limit 32

so, is there a way to prevent endpoint devices from connecting directly to the hub and force them to connect to an electric repeater?

would the best fix be to put an electric outlet repeater in each room and check that each endpoint device in that room connects to its closest electric repeater instead of directly to the st v2 hub? some dont like their closest repeater and stray like a dog.

the problem that i am running into now is that with the direct connect limit of 32 I have a some repeaters (some repeat more then others [example st outlet 7, iris outlet 13]) and a whole lot more endpoint devices.

say I have 10 repeaters and 40 endpoint devices and a few end point devices connect to the repeaters, but the rest of the endpoint devices connect directly to the st v2 hub, maxing out the 32 limit.

if something happens to one of the repeaters, when i remove it then one of the endpoint devices that was connected to that repeater takes its place, maxing out the 32 limit.

I wont be able to add a new repeater until i delete all the endpoint devices that were connected to the bad repeater. thus, leaving an unused space of the 32 limit to add a repeater.

also, ideally i would like to leave some unused spaces of the 32 limit to add new repeaters later on.

the last time I had to delete all devices, delete the hub, re-add it, and first pair all the repeaters so they for sure had a direct connect to the hub with its 32 device limit.

The closest you can hope to do is - Power off the endpoints, then power off the hub for at LEAST 20 minutes (without battery if it’s a V.2) It will cause all devices (not powered off) to go into panic mode and perform a zigbee heal when you turn the hub back on. Once the repeating devices are all operating normally (should only take a minute or so, just test them all) power back on the endpoints and they should heal as they come up. Force a rejoin on any ones that are problematic and they should fall back in line.

after turning the hub back on would i be able to first add more repeaters before power back on the endpoints?

You should. Butnyou cant force how they route. You acn only make conditions more favorable for the repeating devices by bringing them up first.

is it possible to tell which endpoint devices are connected to a repeater without looking at each endpoint?

Not really but quite honestly if you bring up the repeating devices first you should create plenty of routes and not have to worry about it.

Dont try to micromanage the routing, you cant.


I’m a little confused by your question. :thinking: The 32 device limit only applies to non-repeating devices. You can add another repeating device whenever you want (the protocol limit is in the thousands, I don’t know exactly what the smartthings limit is, but it’s at least several hundred.) So if you need more repeating devices, just add those. Then take the hub off power (Including taking out the batteries if any) for at least 20 minutes while leaving all of the other devices on power. This will cause the other devices to go into “panic mode” and when the hub comes back online your mesh network will be rebuilt, with each device picking its best parent under the new conditions.

You should not have to remove a device in order to add a new repeater.

FAQ: 32 Zigbee direct connection device limit?


I am trying to troubleshoot one hub that has about 300 devices (mix of zigbee and zwave) connected were all of the zigbee outlet repeaters (about 20) are offline. also, about 50 zigbee endpoint devices are offline.

I tried to remove and re-pair one of the ST outlets, but it is refusing to re-pair.

That sounds like a different problem. Did you check the IDE to make sure the zigbee radio is active?

Also, you reset the device, right?

yes to both. i was just able to get it to add in the new app and it appeared to work, but only for a couple of toggles on and off. while i could toggle it on and off in the app, when i would toggle it manually on the outlet it would not change status on the new app.

outlet shows in ide as online then offline, but is not responding from the app.

Maybe zigbee interference? Is your hub at least 5 ft away from any WiFi access points or usb 3.0 cords/devices?

zigbee radio is on 14 like it has been for several months. i did find out that they had a brief power outtage the other day.

okay, while at work today on overtime, I started deleting zigbee endpoint devices.

first thing I noticed is that most of the zigbee devices were automatically adding back in with their default device name.

this rules out zigbee interference.

so my question is there a way to stop deleted devices from automatically adding back. is there a setting or do the physical batteries have to be removed from the endpoint devices.

i tried to add back in one of the outlet repeaters and the led light stopped like it paired, but its not showing up on the app.

if we have to delete all the devices and hub to start over fresh, i think it would be wise to max out the zigbee 32 device max with repeaters although some say that the repeaters dont count towards the max, they arent pairing correctly though endpoint devices are.

The “some” who say that only end devices (nonrepeaters) count towards the max includes @tpmanley , who is a senior zigbee engineer on the smartthings staff, so I would go with that. :wink:

i didn’t challenge that. i said that some say that the REPEATERS don’t count towards the 32 max. same thing though in different wording. although why arent the repeaters connecting, over-riding the 32 max connected endpoints.

That’s the same thing.

In Zigbee terminology, a device that repeats is called a “router.“ A device that does not repeat is called “an end device.“

So this statement from @tpmanley

However the routers don’t count against the 32 end device limit and you can add as many routers as you want/need

Means the same thing in a smartthings context as saying

However the repeaters don’t count against the 32 end device limit and you can add as many repeaters as you want/need

Here’s the official spec:

yes, so why arent the routers/repeaters connecting.

okay we deleted all the devices on the hub and deleted the hub itself from the account.

then we hard reset the hub with the button in the back while powering on and it downloaded the latest (newest) firmware.

then re-added the hub to the account.

now we are in the process of adding all the routers/repeaters. so far about 20.

we want to add at least 32 routers/repeaters and then see if we can add additional routers/repeaters past 32.

then we will see if the hub still lets us add endpoint devices as the routers/repeaters should not count against the 32 max endpoints directly connected.

right now we are at 20 routers/repeaters and 10 endpoint devices that automatically added in when we were adding in the routers/repeaters.

1 Like