ST Hub v2 installed but can't pair with Minimote

Some months ago I bought a new ST Hub v2 and a new Minimote, both from UK (UK versions). I had not used them till today in my home in the Netherlands, but when I tried to set-up and pair them today I could not. The Hub can’t detect the Minimote. I reset both (following the steps I saw on internet), and I also tried to exclude the Minimote by following the general exclusion option in the mobile app but also this didn’t give any result. From ST support they told me to confirm if the minimote works also in the UK frequencies, and I checked that this is indeed the case. How possible is that the Hub is problematic (although it is brand new)? Anything else to try?

You should contact support. Please see this thread:

1 Like

I have a new minimote that I am trying to intergrate into ST. It appears to connect but won’t show up in the app. I am then able to exclude it after I cannect it though I have been trying for the last 3 days and cant get it,.