Aeotec Minimote stopped working and says "No network connection"?

My Aeotec Minimote has worked fine for 6 years, then suddenly stopped working in December. In the SmartThings (ST) app, I can see that ST is still receiving its button presses, and the two lights it controlled can still be controlled via the app.

A week ago I made a post here and you kindly folks said it was probably due to a how ST’s backend changed, and I can’t use a custom DTH any more. But I can probably get it working using ST’s built-in Automation.

So I tried using the app’s Automation. I was happy to see that the app remembered which light and dimness setting I wanted for each of the four Minimote buttons.

But right after I walk through the four button assignments and hit “Done”, I get the message:

No network connection. Couldn’t find any available networks.

Which baffles me, because obviously the app and hub are connected and working. Like I say, the app sees any Minimote button presses, and the lights can be controlled through the app. I’ve tried it several times over the past week and always get the same error.

Thanks if you can help!

I am having the same issue with every automation when trying to save them. No network connection. I Haven’t found any fixes yet

Android or iOS?

Saving new or existing Routines?

Have you reported the issue to ST support?

This is on Android and when trying to save existing automations. I have not reported to support yet but will do so.

I’ve been having this issues weeks now. None of my custom monitors are working anymore and every time I try to edit or save a new one I keep getting “No network connection”. Tried resintalling, rebooting router and hub, still nothing. Someone please chime in!

I’ve been meaning to try SmartThings support, like @jkp suggested. But haven’t gotten around to it yet. I’m exhausted by the musical chairs of tech stuff going down that had been working fine. Once you have dozens of types of devices (SmartThings and others), something’s always going down for a completely new reason that you have to figure out. That’s the punishment you get for trying to tech up your house I guess, laugh.

I have reached out to ST support and they asked for a few things, I’ll follow up here once there’s a resolution.