ST hub sending commands but Yale Assure SL Lock unresponsive

yale
zwave

#1

I have an ST hub connected to a TP Link Deco M5 mesh router. I have a Yale Assure SL deadbolt on my front door with the zwave module. I also have an automation routine to unlock the front door when my phone returns home.

When I look at the ST app Notifications, I can see the ST hub sensing the arrival of the phone and sending an unlock command to the Yale lock however the Yale lock doesn’t respond. If I send a remote lock/unlock command to the Yale lock through the ST app, the response is inconsistent, sometimes it works most times it doesn’t.

When I had the ST hub connected to a “conventional” Wifi router, the Yale lock would respond with no issues. It’s in the same location as before about 30 feet from my front door.

I have tried running the zwave repair command and I get the following error message:
Network repair for Yale Assure Lock
[04]: Failed to update route

Should I try to move the ST hub closer to the front door? Any other ideas?

Also, the Yale Assure Lock is the only zwave smart device I have in the home so I’m thinking the distance may be the issue if the ST hub is clearly sending the command to the lock that isn’t responding? (The Yale Assure Lock has 95% battery strength.)


(Head of Support (rboyapps.com)) #2

Try adding a repeater within about 20ft of your lock and it should fix your intermittent connectivity issues.

This is a common problem with locks and they require a buffered repeater to hold messages for reliable operation as the SmartThings hub doesn’t buffer messages.


#3

Thankfully because I have a WiFi mesh router setup, I have multiple routers and I connected the ST hub to the one closest to the front door. As of yesterday evening, the lock is responding to both remote commands and the automation routine is working (where it unlocks when my phone returns home). Will continue to monitor but so far so good! As a side benefit, I have a better understanding of how Zwave works and now need to invest in more Zwave devices to improve the mesh network!


(Head of Support (rboyapps.com)) #4

A quick point to note, not all Z-Wave devices are repeaters. Battery devices are not repeaters and will not contribute to the health of the mesh. Any mains powered Z-Wave Plus device will act as a repeater.


#5

Got it, thank you!