[ST EDGE] Zooz Edge Driver Channel

That happens when it’s a failed pairing. You will need to remove the device and add it again. See the FAQ.

FAQ: Manufacturer/Model Shows All Zeroes

2 Likes

Zooz Multichannel Switch Update - 03/12/2024 Version: 2024-03-13T00:03:19.095592538

  • ZEN17 - Added support for sensor/input child devices. Use the Create Separate Devices for Inputs Setting to create child devices for the inputs, based on the configured input types. Supported for firmware versions 1.04 and higher.
1 Like

Zooz Multisensor Update - 03/21/2024

  • ZSE11 - Added adjustable offset Settings for the temperature and humidity values.
3 Likes

Zooz Multichannel Switch Update - 04/04/2024 Version: 2024-04-05T00:57:01.086678598

  • ZEN17 - Fixed issue with “dry contact” type inputs when using child devices. The child device is now created with the correct type (child-switch).

Zooz Multichannel Switch Update - 04/19/2024 Version: 2024-04-19T21:00:11.728083542

  • ZEN16 (firmware version 2.0 and up)
    Added support for child input devices.
    Added support for input device types.
    Added support for parameters P25, P26, P27.
2 Likes

I have a ZEN34 800LR which I’ve successfully installed. It’s using the Zooz Zen34 Remote Switch driver and I can use it to trigger routines. I can see the advanced settings in “Devices” on the app, but I’d like to control them from other routines. Ex: turn the LED indicator Red when some other condition occurs. I do something similar with my Zen32 devices, but the ZEN34 doesn’t seem to show up as an option when I’m creating routines. I’ve tried waking it up using the 7-tap method but that doesn’t seem to change things. Is this not possible with this device?

The ZEN34 is a battery powered device, which spends most of its time sleeping unless you’re interacting with it (pressing a button) to send a request to the hub. It does WAKEUP occasionally (default is every 12 hours) where it checks with the hub to see if it has anything for it to do (update config, change a setting, etc) but otherwise to save battery its radio is offline and isn’t listening. So sending “blink a LED” requests to it would be pointless, as it would never see it. There are battery powered devices that check in more often (locks for example) but they are a different case and have much larger batteries than the ZEN34 has.

The ZEN32 is a powered device, so its radio is constantly online and can be interacted with at anytime.

2 Likes

Thanks for the insights. I was hoping to be able to at least affect the settings on a routine initiated by the Zen34 itself (eg. IF Toggled up THEN LED Indicator Mode “Always On”) but this doesn’t seem possible either. My new Zen37 (another battery device) has the same behaviour.

SmartThings doesn’t allow routines to update Settings. Only users can do that. Settings are what drive preferences of the device, which in this case map to Zwave parameters.

Now, you could work around this limitation by writing your own driver that:

  • Exposes some capabilitity that routines can call. Maybe you add a light capability that also allows for color change.
  • Map requests for that capability changing (light on, light off, light set to color red) to generate zwave parameter changes on the device.
  • Handle the concept that its a sleepy device, so you’ll need to wait until it wakes up, then send the latest state to effect the led state/color that you’d like.

This doesn’t seem all that helpful, since your physical state wouldn’t change until the next time it woke up (default up to 12 hours, but never consistent from the time of the routine request.) You can increase the WAKEUP INTERVAL to as often as 1 hour, but it will chew batteries.

2 Likes

Thanks for taking the time to explain this! I didn’t have a grasp of how settings work. It makes a bit more sense to me now when I look at the controls like LED Color and Mode which are available in the Zen32, but not the Zen34.

1 Like

3 posts were split to a new topic: Zen 33 Chime Edge Driver?

Zooz Multisensor Update - 04/26/2024 Version: 2024-04-26T18:34:14.183075321

  • ZSE11 - Added support for ZSE11-800LR motion detection.
1 Like

EDIT: disregard. This makes sense for my application. mW equates to milliwatt. MW would equate to megawatt.

I am at a loss. Picked up a Zen 15 but it’s reporting mW which has me all sorts of confused. I’d assume I would see kWH?

Name
Zooz Switch

Description
Supports: ZEN04, ZEN05, ZEN06, ZEN15, ZEN21, ZEN22, ZEN23, ZEN24, ZEN26, ZEN27, ZEN51, ZEN53, ZEN54, ZEN55, ZEN71, ZEN72, ZEN73, ZEN74, ZEN76, ZEN77

Developer
9b8d1eed-1170-6ee7-93ba-451cfd5e815e

Support information

Version
2023-10-22T02:31:19.203743293

Channel
Zooz Edge Drivers

Maybe someone can help me with a different question. Why am I unable to have a graph option for the “Energy Meter” so that I can see how it looks on an hourly/daily basis? How could I make that possible?

Awesome…
Thanks bro🫶🏻

I’m having an issue when I try to install the edge drivers. I get an error that says ‘BadRequestError: Hub (House Hub) does not support edge drivers’

The hub model I have is STH-ETH-250 and it’s running firmware version 000.049.00009

I’ve used this hub before in my old house, but I’m trying to set it up for a new house. I removed that old house and all its devices (I think). I do not have any other devices on the hub yet and am trying to add all my Zooz switches (71, 72, 32, 30)

Any suggestions to try? I haven’t been successful in finding any other documentation on this error.

52.21 is the current production version in the US for the v2 hub (eth-250). My guess is your hub needs to update itself to the latest version to be compatible with the current install UI for driver channels.

It should check for updates whenever it’s rebooted.

3 Likes