Zooz zen16 changed?

Hello. I have a zen16 multi relay controlling my pool pump. It has been installed and working with no issues for a few years now. It is a rather complicated setup where I have physical switches outside as well controlling the different relays but again, everything worked fine until last week. Even after switching to the official zooz edge driver, no issues and that was back in February I think.

Last week on 7/5 I noticed my automations were not working properly. I had things set in the smartthings app to turn on the pump at a certain time and to change pump speed at a certain time. These were triggering but it was turning on the wrong relays. Checking in the app and everything for the zen16 gives a “This device has not updated all of its status information yet. Please check back later.” I had to go back through and figure out how the relays changed. The last reported status was on 7/5.

This unit has been on the zooz edge driver since February. I see that smartthings updated last on may 8th. I don’t see that anything changed last week when I noticed things not working. Is this just the final switchover to edge from ide and I just happen to see it now? Or did something else happen? I have tried power cycling but haven’t tried removing and readding yet.

By any chance were you also using groovy virtual devices in your automations? Because those broke this week. :disappointed_relieved:

Legacy virtual switches stopped working (July 2023)

Possibly? Everything is as it was when I originally set things up years ago so probably yes. I suppose I thought once it switched to the edge driver, that the automations were fine (they were until 7/5.)

Mine switched to edge this week as well. In all likelihood, you will need to regenerate new children, copy routine info over and delete the old children

So I have tried to remove and readd everything. Issues there as well. I could put the hub into exclusion mode, remove the zen16 (says “1 device removed”) but it never actually removes the device. I can literally just keep doing that process and it “removes” it each time but doesn’t actually delete it. Ok fine, I’ll just force remove it. Nope, that doesn’t work either. Says it can’t remove it because the device is working fine. Wtf?

I gave up and tried to add it again. That worked. The one I couldn’t remove just says offline now. It’s like it’s not there (which is correct) but it will not let me remove it. The new one I added is working fine. I renamed the old one “trash” and left it.

try removing from https://my.smartthings.com/advanced or https://my.smartthings.com

Awesome, thanks, that did it.

I have had various issues with ZEN16’s during the edge beta period.
Even though my automations never changed, at various times I had to change the relay type between normally open and normally closed to achieve the same result. Now they seem to to need to all be set to normally open even though 2 inputs are N.C and 1 N.O

I think I am mostly good at this point. Through some effort, I was able to remove all of the existing zen16 items (main and child) then add them back. Verified it is using the zooz edge driver then had to spend some time relearning how everything worked again lol. Set up my automations and everything there is working again as well.

The only issue I have now is I still get the “This device hasnt updated all of its status information yet. Check again later” message only on the parent. However, the history is up to date and shows everything.

1 Like

I have 3 of these sensors, 2 are working fine (only using as motion sensors) and the 3rd is being used as a LUX sensor. For the past 3 days, anywhere between around noon and 2:30 PM, the LUX goes to ZERO (even though it’s way more than that) and then goes back to what it should be, which is totally messing up my lighting automation. I tried a new battery and that didn’t do the trick. Should I remove and re-add? When I first look at the device from the app it says “This device hasn’t updated all its status information yet. Check again later.” Before 3 days ago I never got this message and the other 2 devices don’t give this message.