[ST Edge] Zigbee Driver for MOES 4-Button Scene Switch (TS004F) Plus Some Smart Knob Models

hello how can we find solution for one gang moes button driver? model: TS0041

1 Like

Moes 1 Gang

Interestingly the circuit board looks like it has 3 gangs but only the middle one is solder connected.

If we could add the fingerprint so I can test :pray:

Hi Erickv,

Hope you are well. I can see there are some fingerprints released for the Edge drivers for the zigbee switch in this link SmartThingsEdgeDrivers/fingerprints.yml at production · SmartThingsCommunity/SmartThingsEdgeDrivers · GitHub

Am I right in understanding that your fingerprint for the Yagusmart single and two gang switches should be part of this?

hello, I have installed all the drivers, but ts0041 ( moes 1 gang button) does not support it, do you have any work on it?

Hi @erickv
I just got Moes Smart Knob from Amazon, installed your driver prior to device, and I was able to get it to pair to SmartThings instantly. No issues
Device data

Now I know that this is probably platform issue, but I have no idea what should be displayed on Main part, as currently shows crossed cloud

What is exactly difference between 2 modes?

Is Hold and Rotate (dimmer) available in this driver?
I am trying to have that factory “Press and Rotate” for White Temperature change, however I don’t see how to do it.

Also how Scene mode works? Everything looks the same to me

1 Like

Hello Guys! I’m still lost. I have this MOES 4 Button Scene Switch but I still can’t make it work. Could someone of you guys share a Device Handler Raw Code for me to copy and paste on Smasung Smartthings?

Hi @erickv ,
Can you please add the following to your supported Button Battery Driver , single button:


application: 43

endpointId: 01

manufacturer: _TZ3000_itb0omhv

model: TS0041


Raw Description 01 0104 0000 01 04 0001 0006 E000 0000 02 0019 000A

Many thanks,

1 Like

Hey @milandjurovic71

The difference is how it interacts with the Zigbee network, i.e. Dimmer mode (aka Remote mode) operates across the zigbee groups and it works great with bulbs that have been integrated under the same zigbee group.

The cons about dimmer mode is that the knob would work appart of the ST ecosystem, i.e. it wont trigger automations.

On the other hand, scene mode allows to build ST automations, such as on/off and level-based mirroring automations (for these I use SmartThings Lightning SmartApp).

Note for those interested on adding other fingerprints

Apologies for the lack of follow up =P I’ll be catching up as soon as possible

1 Like

Hi @erickv -
Installed this driver, using a:

  • id: “_TZ3000_czuyt8lz/TS004F”
    deviceLabel: “Modmote”
    manufacturer: “_TZ3000_czuyt8lz”
    model: “TS004F”
    deviceProfileName: 4-button-battery

And it all works well. Thank you for this driver!

Only problem I have is the battery reporting. It shows as 2% even after a full charge.

I’m not sure if this is relevant, but the battery is a built in USB charged battery. (Not a button battery)

I’m just getting started with the CLI so happy to do whatever I can to test anything you need me to?


Would it be possible to add the following:

  • application: 42
  • endpointId: 01
  • manufacturer: _TZ3000_abci1hiu
  • model: TS0044
  • zigbeeNodeType: SLEEPY_END_DEVICE

It’s a MOES 4 Button Scene Remote.

Thanks for adding all these great devices and your hard work.

I am having troubles with the Silvercrest (Lidl) Smart Button. I’ve tried the device handler: Zigbee Non-Holdable Button, but so far no luck. Please Help!


  • application: 47
  • endpointId: 01
  • manufacturer: _TZ3000_rco1yzb1
  • model: TS004F
  • zigbeeNodeType: SLEEPY_END_DEVICE


hi Lucien,
I am not sure whether your question is for the DH or EDGE. If DH, I am using the original “Zigbee Button” handler. Only Single Press works, unfortunately double-press doesn’t work, neither HOLD).
@For the EDGE developers,
the device is capable of Single Press and Double Press in the Tuya/Smartlife platform. (maybe it helps).

These are my settings, still not working with single press.

Hi Lucien,
I have exactly the same version of the Silvercrest (Lidl) button, that you have. (all the data on the back panel of my button is the same as yours).
These are my settings, which work for Single Press (and local execution!)

Maybe consider to delete the device completely. Then pair it again. Probably it will show up as Thing. Change it to “Zigbee Button” directly from this state. Hope it will work for you.

1 Like

These are Groovy Device Handlers (DTH) that will no longer function after Oct. 15, 2022. You should be looking for a computable Edge Driver.

Paul_Oliver, you are right, but my (maybe too naive?) understanding was, that all “default handlers” will be automatically migrated to Edge drivers in the upcoming weeks/months. So my understanding was, that I need mainly focus only on the custom DTHs I use, while the default handlers (like this “Zigbee button DH”) will be migrated seamlessly. Please, feel free to correct me if I am wrong. Many thanks:)
(of course, an EDGE driver would be nice for this Silvercrest button, because the default handler does not work for double-press)

You are correct that is what they said.

But I have been thought 2 platform migrations at work and they both left things broken that the end user had to deal with.

So at the minimum for a new device I would use Edge drivers.

Hi Zoltan: I followed your instructions, but I am not having any success with the smart buttons from Lidl so far. I have 2 and with both it does not work. Thanks for all your help!

4 buttons are in good use.

Thank you for adding MOES 2&3 buttons.

  • zigbeeNodeType: SLEEPY_END_DEVICE
  • application: 42
  • endpointId: 01
  • manufacturer: _TZ3000_4upl1fcj
  • model: TS0041

01 0104 0000 01 03 0000 0001 0006 02 0019 000A