[ST Edge] Z-Wave Plus 700 series based Sensative Strips Sensors Driver [MANUFACTURER VERSION]

This driver causes a catastrophic failure in the most recent version of the Android app. Please see my related post.

Thank you @blueyetisoftware for bring this up, we are trying to get in touch with our developer, @krlaframboise , and we shall, too, try to investigate the problem.


The latest driver published today has resolved the issue. Everything works as expected now. Thanks.


Thank you @krlaframboise and @blueyetisoftware for analyzing and resolving this issue in short time!


@Sensative and @blueyetisoftware - I currently have version 2022-11-07T09:25:36.561226741 of the sensative edge driver installed.

The last two sensative strip guard 700s that I have tried to add to smartthings have been a disaster: in the case of both strips, the device will install, but not register any state change. (The strips are shown as “open” and nothing I do can change the state.

If I look at the strips in the old IDE they are shown as “cloud” executables, not local. This is has been a source of frustration for me for months – I simply cannot get them to install properly. I have tried adding them with the QR code, by letting smartthings scan for them, or by adding with the “manufacture->device type” method. They all produce the same result:

  • strip installs
  • strip shows online
  • no data comes from the strip
  • old IDE shows the device as running in the cloud

What am I doing wrong?

Information for devices using edge drivers can be inaccurate and incomplete if you try to look at them through the IDE. The IDE has never been updated for the new architecture, so you shouldn’t count on it in that regard. It shows a lot of devices using edge drivers as “cloud“ even though all edge drivers run on the hub.

To get accurate information about devices using edge drivers, you can use either the CLI, or a community created webpage interface called API Browser +. It’s not as easy to use the first time as the IDE was since you have to grant access, but after that, it’s got a lot of very helpful information.

Everything @JDRoberts said is correct…

Post screenshots of the device details screen and the bottom of the device settings screen so I can see the state of everything.

Do you by any chance have the WiFi hub?


Thanks @JDRoberts - I should have been more clear. Yes, I was aware of how all of this works, and I do check everything thru the CLI. I just found the information in the old IDE interesting considering these last two strips have been unable to successfully connect to the edge drivers.

Here’s one of the sensative strips exhibiting bad behavior. It’s correctly registered as a ZWAVE device…
131 North Gate sensative-strips-guard-700 ZWAVE 1bf65300-e4f9-4941-bf6e-2e9cb7161eba


hi @krlaframboise

Here’s the screens from one of the Sensative devices. (No, the battery is not at 1%, it’s a brand new device, it’s just not reporting any information.)

My Hub is a V2, and it’s connected via ethernet, not WiFi

Does the tamper tile change when you manually wake it up? The wake up procedure is the same as inclusion.

No, it doesn’t. That’s why I started poking around in the IDE. It doesn’t look like ST Hub is receiving any data from this device beyond the initial inclusion.

This has been true for this device and another I added afterwards. Since these things are relatively expensive, I didn’t want to waste any more until I have a thorough understanding of what is happening.

This is interesting @krlaframboise - I just took a look via the API Browser (which I didn’t know existed, so that’s fantastic) and I can see that it is failing the S2 security check:

1 Like

Try rebooting your hub.

Did you use the qr codes on the device when adding it?

I will give the hub a reboot later today and see if that helps.

Yes - I used the QR codes…I also tried letting the hub scan for new devices, and using the “find by brand/model” option when onboarding. All three methods have the same effect

@krlaframboise I rebooted the hub, and one of the sensative strips started reporting (although it still shows 1% battery, which is weird - does it take a white to report the battery state?) Thank you for that!

The other one, though, did not show. I removed it, tried to re-add it - and now it refuses to re-add. It also refuses to factory reset.

Is it still showing 1% battery?

Are you able to get the other one to flash the led 3x when attempting to add/remove it?

I have had really bad luck with these strips and started removing them. They claim up to a 10 year life, but I started having mine die in under a year. They are willing to replace them for you when they die, but it is a huge hassle depending on where you mount these.

1 Like

I replaced two of these this week after the batteries died and the new ones are not working well. The old ones worked fine in the same locations.

Both paired fine and passed initial testing. After that one of them never reported again but the tamper alarm now shows up. The other one does report open/close activity but says it hasn’t updated all of its status information and to check back later, it’s been saying that for 5 days. The tamper icon looks like it’s still waiting for a status. Both show 100% battery.

Neither came with the round magnet the directions say to use for resetting. I tried using the flat one that was in its place but nothing happens.

1 Like

Hello @Stephen_Johnson,

Please create a ticket on our website, and we will be able to help you: Contact Sensative

1 Like

Hello @uberrob,

Please create a ticket on our website, and we will be able to help you: Contact Sensative

1 Like