[ST Edge] Virtual Things Edge Driver

Yeah I’ve tried with my phone and my tablet (both apple) and the device didn’t came up…
After your message I decided to try with my wife’s phone which is ANDROID and BOOM now I got the device!
Thank you!

1 Like

@ygerlovin thanks for all your work on this driver.

Is there any way of adding (hidden) contact sensors to be associated with the Open, Close and Pause buttons of the Curtain device, so that Alexa can see them? I have a few RF roller blinds that I have connected to Alexa through a Broadlink hub. I’d love to use a ST routine to tell the blind to open or close, and then have those commands pass through to Alexa to drive the blinds through the Broadlink connection. I know I can set up vMomentary switches to get through to Alexa, but that would require 4 virtual devices (Blind, open/close/pause switches) and up to 6 ST routines to mirror the state of the switches. With 10 blinds to control, that would mean 40 devices and 60 routines. If the virtual curtain has 3 contact sensors (is that even possible?), it would reduce the overhead enormously.

@RebelMagpie

Unfortunately, I don’t think Alexa supports multicomponent devices as trigers.
So, even if I add 3 sensors to Curtain device, only the sensor under main component will be shown in Alexa.
Don’t think it is what you are looking for

Thanks @ygerlovin, I figured that may be the case. I’ll investigate some other options.

I’m surprised there’s not a simpler way to integrate RF devices than having to go through Alexa and Broadlink, but that’s another topic.

Actually @ygerlovin, is there any way you could add just one contact sensor to mirror the Curtain On/Off switch? That would give me open and close commands to send to the physical device, which would achieve 95% of what I need.

You can use the Bond Bridge for RF/IR devices. I have an Edge driver available for both models. It’s intended for RF shades, fans, etc. The cheaper one also does IR. The Pro version does not.

Thank you so much @blueyetisoftware. I will look into getting a Bond Bridge. Sigh, I have so many bridges dotted around my home, but I guess this one will replace the Broadlink. I don’t suppose you feel like writing a similar Edge driver for the Broadlink bridge (or if it is even possible)?

Please don’t answer here - not related this discussion. I’ll take it up any further discussion in your Bond Bridge LAN thread.

Hi @ygerlovin, I have been playing around with the vCurtain device created using your vDev Controller to sync a curtain back and forth with a device in Alexa.

If I Open or Close from within Smartthings, the state of the Alexa vCurtain changes appropriately.

In Alexa, the only way I can see to change the state is to move the slider in the device. When I do this, I get an error saying “Device is unresponsive”.

If I use an Alexa routine to Open or Close the vCurtain, nothing happens.

When it first happened, I deleted the vCurtain and tried creating another, with the same result.

Is this expected? Am I doing something wrong?

@RebelMagpie

If you manually open/close completely in Alexa, does the state change in ST?

No, nothing happens in ST when I completely open or close the shade in Alexa. If I do that, the shade moves and the “Opening” text changes to “0 Percent” (or “100 Percent” as appropriate), the “Device is unresponsive” message comes up for 5 seconds and then disappears. The shade stays at the end I moved it to and the text stays as “0 Percent” (or “100 Percent”), but nothing changes on the ST vCurtain.

However, if I Open or Close the vCurtain (or toggle the power switch) in ST, the Alexa vCurtain tracks it correctly.

@ygerlovin Would there be any reason why I’m not seeing a simulated lock as being available to add into ActionTiles? Everything other one of the virtual device types seems to show except this.

Hi,
vDev Controller stop working today.

And all the virtual buttons created before are not working either.

It happens to someone else, or it was only to me?

Thanks

Try rebooting your hub. I have had individual problems before and that fixed it.

Hi @Paul_Oliver ,

I tried that before write here, but didn’t fix the issue.

But now, after a good sleep night, is workinh again. :slight_smile:

Thank you.

This is great stuff, thanks for the work on all of this!

Question: how are the data values of these devices updated? For us beginners (at this, anyway) is it all done through the routine rules? I’m not ready to tackle the rules API yet.

So it seems to be simple with switches…but I’m trying to get a virtual thermostat running.

My only options for temperatures are Matches, Equal or above, Equal or below, and Range. I can’t find “if the temperature changes”.
In addition, what would be the best way to average a couple of temperature sensors, and use that value to drive the thermostat?

Thanks!

@ygerlovin - This is the 5th time that my switches are getting stuck and not letting the automations trigger. Is there a way to permanently resolve this as I need to delete and recreate a new switch every time this happens? I have a V3 hub and tried hard and soft reboot several times but no luck.

Once the fix the bug for switching drivers. You can briefly switch the driver to a different developers virtual switch and then back again to the one you were using, and it should fix the problem.

Sort of what I did before Paul and it worked but when I tried again now, there was no luck so had to recreate two new switches and add it in 40+ automations. Is this the only way out till the developer fixes it?

Switching drivers or hub reboots have always fixed the problem for me.

If that does not work you could always try a different developers virtual devices. There are at least 3 available.

Another option are virtual devices created by the CLI or Simple Device Viewer. These reside in the cloud, so they will not give you local exacution.

Hi @Subramanian_Swaminat ,

Would it be possible to provide a log?
I suspect the issue is related to recent hub updates, momentary stopped working for me without any changes to driver, but switches are working fine.