[ST Edge] vEdge Creator: a virtual device generator for end users

I can’t proceed, it just stays on this screen.

Were you able to solve your issue on the iPad? I tried it myself, and it works OK for me. Sometimes you just have to exit and reload the app, or give it a lot of time to update before you try anything.

You’re correct, it’s working now. I don’t know, but I cleared the ST app out and forced a reload before I sent the message and it still didn’t work.

Thanks for checking, and thanks for the driver…it’ll help a lot!


1 Like

Thanks for this driver @TAustin !

I had one virtual switch and six virtual dimmers that I created a couple of years ago using the IDE.

I had no confidence these would be automatically migrated so I used your driver to create replacements. Not one of the more complicated use cases for this but helpful to me!


Thank you for creating this, it’s very helpful!

I have tied an on/off routine to a momentary switch, Alexa discovers them but quickly decides to delete them… it’s not deleting any other type of switch so there’s something about vEdge that it is not liking…

Any ideas?

It’s worth noting that the virtual device creator provides a serviceable workaround for a current limitation in the Edge/Lua platform.

There are lots of hardware components that consist of multiple devices. The Zooz ZEN30 is one example, which consists of a dimmer switch and a child relay switch (designed to control ceiling fan/light combos). But the new Edge/Lua platform does not support the separate control of these devices, because the Edge driver cannot create multiple device controllers. The result is that the ST app will only display one device, while the child device is accessed only through the extended/advanced device settings. This limitation means that connected services (e.g. voice control) cannot see the child device and therefore it cannot be controlled.

By creating a virtual switch and connecting it to the hidden, child device via on/off routine, the child device has a separate representation in the ST app and can be controlled accordingly.

In short, @TAustin’s virtual device driver is essential to the new ST platform. Thanks for creating it.


I’m noticing something very strange with the virtual thermostat, I have nine of these to control various zones around my house. All of them have the “mode automation” turned on, and all of them are randomly and frequently flipping from “idle” to “heating” for no explicit reason. The temperature is not changing, and frustratingly this is happening even if the temperature is above the heat set temperature.

I’ve created one more without any automation attached to it, to see if it exhibits the same behavior, after this I will simply create a simple automation to adjust the temperature from time to time to test the mode automation… I’ll report more soon.

Keep me posted what you find. I would suspect you may have a temperature attribute getting changed which is triggering the state change to heating: either the heating setpoint getting set higher, or more likely, the ‘actual’ temperature dipping below the setpoint.

Let me know your exact settings and I can try to duplicate.

1 Like

So after creating my test thermostat, and slowly applying the same automation, it appears to be behaving as expected… and for no reason that I can see all the others are as well :man_shrugging: very confusing. The behavior I saw earlier wasn’t just momentary “flipping” it was very fast and sporadic, nothing any of my automation would’ve done (since they are based simply on the temperature changes of various sensors). The actual vTemperature never changed while this was happening (at least according to the history). I would see the mode change a dozen times in a few seconds, stop for a bit, and start again on every single one of them (not all at the same time, but on multiple at the same time). Now it seems whatever was the cause it’s gone.

I’ll continue to monitor. I saw this happen yesterday on a few, but thought it was a minor display issue (until I noticed my radiators staying on when they shouldn’t), later today I noticed it on all of them. Now it’s all quiet… for no reason :confused:

OK, maybe chalk it up to a strange platform glitch. Let me know if you catch it again!

1 Like

I found the issue.

I have an automation that ensures when my boiler is in “winter or summer mode” turn the thermostats to “off” or “heat” respectively.

This gets triggered if a radiator gets turned on (I have removed this now, as it doesn’t really make sense, as they shouldn’t turn on w/o a command from a thermostat going into “heating” state).

However, I think there is a bit of a bug when a thermostat is turned to “heat” it automatically enters “heating” state, even if the vTemp is higher than the Heating Setpoint. So any automation which turns the thermostats to “heat” inadvertently also kicks off the state to “heating” even if the temperature is not correct.

I tested this on a new virtual thermostat w/o any automation and every time I set the mode to “heat” the operating state jumps to ‘heating’ - and thus this explains why my thermostats were all jumping back, as the “mode” was being set to heat at the same time as the operating state was attempting to change to heating, and I’m sure causing a loop with this particular automation rule.

See this link with a video capture of what I’m seeing.

Have you not come across the EDGE_CHILD devices being retrofitted to a number of stock Edge drivers in the last quarter of the year?

1 Like

Got it. Let me look at this in the code.

1 Like

Found the problem and fixed it…

Driver Version 2022-12-30T01:29:45.148168554


@tmielonen I had not. Literally yesterday I installed the ZEN30 Edge Driver, saw that the child device was hidden, read about the issue on the Zooz support page, reached out to Zooz support, received a response confirming the limitation, and tested the virtual switch workaround. I even passed the workaround along to Zooz support, and received a second response. Today I received a message from @Paul_Oliver that the ZEN30 driver had just been updated (actually collapsed into another multi-sensor driver). I reinstalled today and now have the option to spawn the child device into the ST app. I think I just picked a bad day to migrate those devices. :slight_smile:

In any case, virtual switches play a critical role in my setup, so I’m glad to have found this one.


Thank you!

Do you know what the format is for humidity?

  "commands": [
      "component": "main",
      "capability": "partyvoice23922.vhumidityset",
      "command": "setvHumidity",
      "arguments": [

Thank you that worked.

1 Like

I am getting same problem using virtual energy meter. It keeps turning switches on/off randomly. When I stopped using it, it’s normal