[ST Edge] vEdge Creator: a virtual device generator for end users

Sorry if I wasn’t clear. I have smart blinds that work with Alexa. I wanted to use the window shade virtual switch with an Alexa routine to enable ST routines, but the virtual window shade doesn’t currently show up as a trigger for Alexa. Right now I’m using the contact sensor which works but I’d like the icon to be the blinds

Ok. I see. I think there is no solution for this. There has been discussion about it in some older threads. You could contact developer and ask if it is possible to add shade icon to it though.

Thank you @TAustin for this solution. It neatly solved my issue of getting Alexa to announce one or more of my garage doors was open between specified hours. I’m already looking forward to replacing all of my virtual switches to achieve (finally!) a lot more local execution.

(Just realized this is my first post in, well, several years!)

2 Likes

Awesome! Glad it met your needs and thanks for posting :+1:t3:

Perfect! Tested and love it. This saves me a ton of time. You are the best bro!

2 Likes

Hey @TAustin really appreciate your hard work with this as I’ve created a lot of virtual devices using your driver…for several months now, so many thanks!

However, two nights ago, I rebooted my SmartThings V.3 hub, and when it came back online, none of the virtual devices that I created with the vEdge Creator were responding.
I have several device types using the V2 driver and they all are inoperable right now. When turning on/activating any of these virtual devices the button will rotate for about 5 seconds, then an error: “A network or server error occurred. Try again later.”

When I try to create a new virtual device using the generator, it will time out after ~5 seconds with the same error as above.





What is interesting is that I still had the v1 drivers installed, so when I change a device from v2 to v1, the device works again.
I can also use the v1 Generator to create a new virtual device, which works (using the old driver), so then I change the v1 device to the v2 driver, and it stops working again.

What is also interesting is that there are NO logs created for the above issues when they occur in the IDE or in the ST app.

I also have several virtual edge devices that use ygerlovin’s drivers with no issues.

I’m assuming I could change all the v2 devices to the v1 driver, then reinstall the v2 drivers and then switch all the devices back to v2? I have SO many drives with complicated routines, that it scares me to uninstall the associated driver – as I believe that would uninstall all the devices using that driver, is that correct?

What are your thoughts?

Here’s the hub’s info:

Hub Firmware version: 000.042.00007
Hub Hardware version: Hub v3 US

Zigbee:

  • State: Functional
  • Version: 5.4.0
  • EUI: 286D970002003681
  • Channel: 14
  • Node ID: 0000
  • Pan ID: 82C0
  • OTA: enabled for all devices
  • Unsecure Rejoin: true

Zwave:

  • State: Functional
  • Home ID: D6916F2A
  • Node ID: 01
  • Suc ID: 01
  • Protocol Version: 6.04
  • Region: US

Firstly, I’m really sorry for the trouble you are having. It sounds like with that last hub reboot that for some reason the driver did not get successfully restarted.

My recommendation would be to reboot your hub again to force the driver to re-start. Hopefully that will get your devices working again.

3 Likes

I’ve been in IT for a long time my man, so I respect your answer - REBOOT IT!!! However, I rebooted the hub several times after turning off most of my devices and disabling a lot of automation. I left it alone and went to bed. Woke up today and it’s all working now.

I’ve been on the ST platform since launch, and I’ll tell ya, that was a crazy flap my man.

Thanks for your work.

1 Like

We’ll these are quite frustrating situations. As the Edge platform is still in beta it’s possible this was just an anomaly - they seem to happen less often with zigbee & zwave drivers. Personally, I see regular cases where a driver (re)install doesn’t always run to completion, thus my recommendation to reboot the hub. But why you saw such a long delay before the driver started working again, is a mystery.

I recommend to anyone using Edge drivers to have the CLI available because with it, you can force driver reinstalls and monitor progress via log output.

Anyway I’m just relieved that your devices are working again; I appreciate the huge pain it would have been to have to recreate them and their associated routines!

2 Likes

Yeah my man, it was hard to go to bed w/o resolving it, especially since I rely on a lot of virtual switches to run automation w/ external services. And yeah, not being able to see logs is painful, so lesson well learned.

Thanks for your work!

I hope all this Edge stuff stays stable because I currently have a total of 21 various virtual devices running using this driver. Thank you!

BTW, the one thing that I was running Webcore for to flip a Virtual switch On/Off when the v2 Hub was On/Off its internal battery power stopped working after the last Hub v2 firmware upgrade. So I’ve now had to switch over to a dedicated canary smartbulb solution which only triggers when power is restored. So do you know if SmartThings exposed the v2 Hub battery power condition somewhere in this new Edge programming language where it shows when the v2 hub is on battery power and when it isn’t? If they have, then since SmartThings themselves do not support any battery condition switch on their hub device driver, maybe a Virtual device could follow the On/Off battery condition to trigger routines when there is a power outage and restoration of power.

Not that I can see. If I display capability status for the Hub using the CLI, it shows a ‘bridge’ capability but nothing else. And it shows no status for ‘bridge’. If I display health status for the hub, it shows only deviceID, state (.e.g. “ONLINE”), and last updated date.

1 Like

The bridge capability is a relic like actuator and sensor.

I don’t think the hub battery status is exposed in any way that it can be subscribed to. It might be tucked away elsewhere when you view the hub through the devices or installed-hubs endpoints but I can’t remember and I just got distracted by a device type for virtual devices that is now in the API …

1 Like

Where are you seeing that? They had hinted this would be coming eventually for Edge drivers. My understanding was that it would allow for drivers to be created without having to specify LAN permissions. Hopefully it would still allow for try_create_device() method.

One place is
API | SmartThings Developers where they show all the different types like zigbee, viper, matter and now virtual.

I’m interested to see where they go with virtual devices. Edge can only help so much as we need cloud based virtual devices too.

I’m rather hoping for a new approach to creating devices that don’t need discovering.

1 Like

It’s still beta, I would count on it being unstable for awhile.

Hopefully once we’re into full production it will prove reliable, but no way to know yet.

It may also end up being reused for Matter. Time will tell.

I’ve been completely reinstalling my Location in the last two days, as I thought it was about time I got it on the EU01 shard to match my UK accounts, and I also switched the ownership away from my personal account. Yesterday I was having problems with the first hub I migrated returning a 403 error when running logcat so I thought I’d give it a factory reset today. It still returns a 403 but more surprising to me is that it installs vEdge Creator 2.3 when I do a Scan Nearby (just the once unless deleted). I find this a little odd for two reasons:

  1. The device doesn’t give me the ‘Driver’ option in the settings, and nor do any devices created using it.
  2. The app and the CLI tell me that it is not enrolled in @TAustin’s channel and does not have the virtual devices driver installed. It was enrolled and the driver installed before the devices and hub were removed and supposedly factory reset, but I haven’t done anything since.

Confused? You bet I am. Did I forget to do something?

That is freaky! Sounds like a glitch in the matrix for sure. And it sounds like besides the Driver option not being shown, the virtual devices are functioning normally?

You didn’t say, but to prepare for this migration, did you delete all devices and remove all drivers from the hub first? Or did you leave everything intact?

I certainly deleted the devices. If I went wrong anywhere it would be in not clearing out the drivers thoroughly. Then again I didn’t expect anything to survive a reset.