[ST Edge] Philips Hue LAN [BETA] (3rd Party Driver, Not ST Native)

Right on, thanks! One of my hue bulbs fried, replaced it, hadn’t kept up on things… And here I landed! I’m back in action

I am missing settings and link menu. Please help. Thx

same problem.

This is a know issue, See this post [ST Edge] Philips Hue LAN [BETA] (3rd Party Driver, Not ST Native) - #698 by blueyetisoftware


unfortunately it doesn’t work for me

Still missing linking option.

thanks for the help

You need to scroll down to the commands section


Yeah, I can imagine it would be. Just know that even in the current state, I’m still very happy with this driver and very appreciative of all the help you’ve been providing.


It worked with my new Smartthing station and my Philips bridge
It did not ask me to authenticate with a button, but it did not update me, however by following the steps in the link above I was able to manually make my lights and motion sensors appear with all the functions, thank you!

This driver is working well for me, having to use the discovery workaround but that’s OK. I would like to implement the normal dimming control from Hue dimmers and tap-dial switches though. Is there any way to do that? If I use the dimmer straight from the Hue app I lose the power of being able to assign routines to different button presses, or I move it to this driver and lose the dimming controls.

Supplementary question; what’s the difference between Toggled_down and Pressed?

1 Like

Is anyone using this driver and Sharptools? I’m struggling to get the color right when triggering colors via SharpTools rules. Any suggestions that have worked for you?

Are you using the setColor() command with a hue, saturation, and level?

What are you having trouble with?

Yes, that’s what I’m using but the colors don’t seem to match. I found the Hue and Saturation from the Smartthings Advanced app after setting them to the color I wanted. The color I set doesn’t match the color set via SharpTools.