[ST Edge] ONVIF-compliant IP Camera Motion Detection & Video Streaming - Testers Wanted!

Hello @TAustin, very good work! very good tool! Thanks!! :clap: :clap:

Device Type: Dahua IPC-HFW1120S (5x cams)
added: perfect, 1 shot.
motion event: YES
live video: NO :disappointed_relieved:

Device Type: Dahua IPC-C35 (2x cams)
added: perfect, 1 shot.
motion event: YES
live video: 1 cam, very slow, very eventually but yes. (the other one, never)

Device Type: TP-Link VIGI C300HP (1x cam)
added: perfect, 1 shot.
motion event: NO subscribe to events (camera motion: ON) :person_shrugging:
live video: YES, always, very quickly.

Dahua IPC-HFW1120S (2015) & Dahua IPC-C35 (2017):
This cameras might be having a problem with ONVIF authentication.
Something that I perceive because there is no ONVIF configuration manager. Only ONVIF authentication: ON or OFF. There is no handling of user account and related permissions.
So i think it could be cameras with a very basic version of ONVIF, maybe not working properly.

I have a Sannce NVR with 4 POE cameras that get discovered, are configured and added to a group but I dont get any video streaming. I have them configured in an Android APP called Onvier and they work perfectly so I know I dont have an authentication issue and I dont appear to be getting much out of the CLI (I am new to the CLI).

2022-09-30T15:33:03.502835767+00:00 TRACE ONVIF Video Camera V1.1 Found CapabilityCommandDispatcher handler in onvifDriver
2022-09-30T15:33:03.508299434+00:00 DEBUG ONVIF Video Camera V1.1 Streaming handler invoked with command startStream
2022-09-30T15:33:03.514203434+00:00 DEBUG ONVIF Video Camera V1.1 IPCam #4 (configure!) device thread event handled
2022-09-30T15:33:03.612643101+00:00 TRACE ONVIF Video Camera V1.1 Received event with handler capability
2022-09-30T15:33:03.702695434+00:00 INFO ONVIF Video Camera V1.1 <Device: effff3f5-0259-4b00-8c7a-dec22f8931a9 (IPCam #2 (configure!))> received command: {“args”:{},“capability”:“videoStream”,“command”:“startStream”,“component”:“main”,“positional_args”:{}}

The camera model reports as an IPCAM-100

I dont suppose anyone has any suggestions? - I’ve tried a hub and camera restart but still nothing…

Hi @TAustin i’ve a reolink 410w and It worked fine with onvif driver 1.0, now with1.1 It doesn’tn respond.
I’ve tried to change resolution to 640x360 and set a password without @ or ?
What can i do? Smartthings find the cam immediatly.
Thank you

It’s strange that it would stop working with the later driver.

Would it be possible for you to install the SmartThings CLI and run some logs? This would allow us to see exactly what is going wrong when trying to connect to your camera.

If you have a Windows machine, it’s a simple procedure to download and install it. Here is the link. Send me a direct message when you have it and I can walk you through what you’ll need to do.

After putting my son to bed i’ll try to install cli, i’m not an Expert but a simple user.
it was a long time since I hadn’t looked at the cam in Smartthings anymore because I received notifications from the app reolink. I found the new driver and without thinking I updated it and it no longer worked, but I don’t know if it still worked with the old driver.
I have to click on that link from a PC with Windows, install the software and then? sorry for my ignorance.
Thank you and thanks for your work.

No problem. I’m happy to help. If there is something I need to do in the driver to make your camera work, I want to know!

If you click on the link and download the .msi file and then run it, it will install the CLI to your Windows machine.

Once you do that, you will open a Windows command prompt window (type ‘command prompt’ in the search field if needed). Then to run the CLI you simply type smartthings and hit enter:

C:/users/francesco> smartthings

You can try different commands to make sure it is working, for example:

smartthings devices

The first time you run a command like this, it will open a browser window for you to authorize access. Once you do that you can return to the command prompt window.

To start logging you would use this command:

smartthings edge:drivers:logcat

You will be prompted for the driver, so choose the ONVIF Video Camera V1 driver.

Once you have that going, you can press the Refresh button in the mobile app device Controls screen for your camera. You should see a bunch of messages come out of the CLI at this point. Copy and paste them here, and be sure to start and end the log text with triple backquotes (```). This will ensure readable formatting.

1 Like

Hello @TAustin

I would like to ask you if the driver works with the RTSP protocol for live video.

In my case I was able to verify that for my DAHUA cameras the only address that works well is the following:

rtsp://admin:admin@192.168.1.201:554/cam/realmonitor?channel=1&subtype=0&unicast=true&proto=Onvif

The password must be entered admin/admin because for some reason my version of ONVIF does not allow setting a custom password.

Since I can’t see any DAHUA cameras live from the driver in SmarThings App, what RTSP address does your driver query? Is there any way to make it adaptable?

I have tried other addresses without success, for example:

rtsp://192.168.1.201:554/live

About the URL of the RTSP, please see the explanation as follows.

URL Syntax

rtsp://:@:/cam/realmonitor?channel=&subtype=

** : a valid user’s username.*
** :user’s password. (Cannot contain #)*
** :the IP address of the IP Camera.*
** :the default port is 554. It can be omitted.*
** :the channel number. It starts from 1.*
** :the stream type. The of main stream is 0, extra stream 1 is 1, extra stream 2 is 2.*

More at: DahuaWiki

@TAustin
Hello friend.

Ive got reolink E1 pro camera.
I use your driver and it’s discovering the camera with the IP in the reolink app.
I put the id and pass in the driver setting but the camera is not responding, when I try to turn on event it goes off . Same when I try to see the streaming, nothing happens.

Tried few times. Nothing.
What can I do wrong?

I the reolink app everything working.

Do you have the latest firmware installed in your camera?

yes i am on the last version. checked on reolink site.

Make sure your userid/password doesn’t contain any special characters, and check your Reolink app and make sure there aren’t any camera settings you have to turn on to enable ONVIF.

If you are willing to install the SmartThings CLI, we can get log output from the driver and that will allow me to see what the problem might be. If you have a windows machine you can download the windows installer here.

For my RLC-510WA the ONVIF setting was buried in the PC Client settings under Network I believe. Then I either had to go into “set up” for another setting or it appeared after toggling another setting, or maybe both. I wish my memory was better. Point being is I was unable to find it in Android app or camera settings on NVR, only in the client.
Edit: @TAustin it was Network/Advanced/Port Settings then toggle RTSP and it automatically toggles ONVIF.

1 Like

Hi,

I installed Reolink E1 Zoom and it is working fine.
Is it possible to get a photo from the camera when detecting movment by the camera or other sensor in the smartthings platform?

Thank you!

Guy

1 Like

It is technically possible to do, but unfortunately there’s nothing I can do with an image in the context of an Edge driver. There is no way for me to display it in the SmartThings app or send it anywhere else. That would require a SmartApp.

Thanks for your reply.

So what is the benefit of the driver? Making the camers a motion sensor?

Thanks

Pretty much that. The video streaming is interesting, but I always thought the manufacturer’s app would do a better job at that. Video streaming from an Edge driver is actually not officially supported, so we have what we have…

EDIT: I’ve been working on adding tamper and line cross event detection. It may not work for all cameras, but for anyone interested in trying it out, let me know.

@TAustin - Tamper and line cross is still looking good for me on Tapo range cameras :+1:

1 Like

Yes, I owe you a comeback! Need to focus on your logs…

EDIT: Is your regular motion getting triggered?

Line cross for me on a Hikvision has proven to be difficult to observe and iron out

My particular device is complex in its abilities even for Line crossing so i have been unable to corralate Onvif driver line cross with manufacture recording of event

Hi, yes I think all is fine (will happily check if needed). I raised the repetitive line cross event on the TP forum but no real joy apart from suggesting I raise it on an ODM/ONVIF thread and, frankly, I couldn’t be bothered…

Your driver is all good from my experience so far though :+1:

1 Like