[ST Edge] Issues with multi-component devices and third-party integrations

Has anything promised that Edge drivers would be backwards compatible with the all the abilities present in existing DTHs?

Of course not, but that is the purpose of this forum so the smartthings team can hear our feedback from testing edge beta drivers and provide changes or workarounds if needed, as this is still work in progress.

And I strongly believe that handling of multi gang switches by smart speakers is a must, as for sure a lot of users use such things and a lot of companies sell them.

So @nayelyz if possible talk to engineers please and let us know if any workaround could be provided.

2 Likes

You’re right, Edge drivers are a work in progress, the team is constantly working on improving their functionality.

I already created the report for the engineering team, once I get more information, I’ll share it with you.

6 Likes

Hello, I hope the developers are able to address this. For my Aeotec Nano Dual Switch (ZW132-C), with a DTH, I had 2 separate virtual devices to control 2 physically independent loads. With the Z-Wave Switch Edge driver (stock and 3rd party), I now see 1 virtual device with 2 sub switches: Main and Switch 1.

The two physical toggle switches continue to control the independent loads.

From the app, the power button on the tile controls both loads.
Inside the device, “Main” controls both loads, “Switch 1” controls 1 of the loads. There is no way of controlling the second load virtually. (So a virtual switch won’t work either).

Even if this did work, it’s not a good UX compared to the DTH, where independent loads showed separately (from the same physical module). If I had to create virtual switches as workarounds, I’d need to have 6: 2 to handle the physical toggle switch changing the virtual switch status, 2 to control the virtual switches being switched on and 2 for off (yes, I know I could use on/off).

Please, please revert this behaviour or at least give the choice of having a child device.

I have reverted back to DTH for this device, but hope the developers see fit to tweak this before DTH is finally sunset.

Thanks :slight_smile:

2 Likes

Can you try this version of the Z-Wave Switch Mc to see if you can control channel 1 with main and channel 2 with Switch1 from the app?

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Z-Wave Switch Mc                     │
│ Version     │ 2022-03-15T16:23:17.548625           │
└─────────────┴──────────────────────────────────────┘
1 Like

I am having the similar issues as @lewisburgess with z-wave dual switches using both stock z-wave switch driver and z-wave switch mc driver with Minoston Z-Wave Plug Outlet Dual On/Off Switch Outlet (MP20Z). I have no control of the second outlet using either driver.

Issues with Z-wave switch driver

With this latest version either?

I will try once it updates and it and report back. I still have verson 2022-03-11

1 Like

I still dont have this version available.

I published it again, just in case.

If you have the CLI in use you can install it immediately with the command
smartthings edge:drivers:install

1 Like

This now works to control both loads with the Minoston Z-Wave Plug Outlet Dual On/Off Switch Outlet (MP20Z).

I am fine with this version but wanted to note that the switches don’t control the expected outlets.
Main controls the Right (secondary) outlet and Switch 1 controls the Left (main) outlet. Thank you for fixing this!

Hi,

This is improved on the Fibaro Double Switch

Main controls 1 load and Switch 1 controls the other from within the app.

But, there is an issue in the app changing state when either toggle switches change state. Looking at the logs, the hub is not seeing a state change and therefore, the app state is not changing. I have occasionally seen a button “pushed” but rarely.

Secondly, I use an IKEA button (with an Edge driver) to control some bulbs and both of these devices in a routine. There is a very significant delay in the Fibaro Double Switch switches changing state. The bulbs fire straight away. In a different room, with a Fibaro Dimmer and several bulbs, the states change straight away.

I haven’t tried removing the device and re-adding it. It’s the only Fibaro Double Switch I have. The Single Switch seems to be the same as before (you know I have a case open with ST about this). The Dimmers all work as usual. I removed my Aeotec Double Switch entirely as I have no use for it elsewhere in the house so I can’t try this (as you know, I was having big trouble with this).

I’ll send you some logs in a PM.

Thanks :slight_smile:

I didn’t change anything for the fibaro double switch. It Use the stock driver code.

I have one with the driver and it updates the toggle states change in the app correctly and without delay.

Oh, well it has improved - so something’s changed!

What would you like me to test?

I thought you had a problem with the double switch aoetec, but it seems that you no longer use it

Ah yes, sorry. It was so bad I had to remove it. I have mentioned it privately to ST in my support case about the Fibaro Single Switch and asked if they’re serious about be doing some diagnostics on this. If so, I’d reconnect it. But it is quite a pain to do this so not ideal.

Hi Mariano,

I tried adding the Evalogik Outlet using the Z-Wave Switch Mc driver.
- id: 0312/C000/C003
The app updates when the physical outlet is switched but I am unable to control via the app. I tried restarting hub, removed and re-added device without any luck a few times. No errors seen in logcat when adding.

Also, would you please add this Minoston Outdoor Dimmer MP22ZD at your convenience? Thank you

Raw Description: zw:Ls2a type:1100 mfr:0312 prod:FF07 model:FF03 ver:1.00 zwv:7.13 lib:03 cc:5E,55,9F,6C sec:86,26,70,85,8E,59,72,5A,73,7A

Try to capture the log when you turn on and off then device from app

Try this version v4 with the double plg and with the single
the changes I made yesterday fixed your double plug, but it messed up the single plug on some devices, each manufacturer works differently.

Added dimmer Minoston

  - id: 0312/FF07/FF03
    deviceLabel: Minoston Dimmer
    manufacturerId: 0x0312
    productType: 0xFF07
    productId: 0xFF03
    deviceProfileName: switch-level
┌─────────────┬──────────────────────────────────────┐
│ Name        │ Z-Wave Switch v4                     │
│ Version     │ 2022-03-18T18:04:48.886215           │
└─────────────┴──────────────────────────────────────┘

This works well with the following devices
Evalogik 1ch Outdoor Plug ZW96 - id: 0312/C000/C003
Evalogik Outdoor 2ch Plug ZW97 - id:
Minoston Outdoor Dimmer Plug MP22ZD - id: 010F/0102/2000
Minoston Dual Switch MP20Z - id: 0312/FF00/FF05

A few questions…
Do you have a github for your z-wave drivers? All I can find is your zigbee drivers.
How can I get the device id for edge devices?

Thank you so much for all your work and patience! You are very much appreciated.

2 Likes