[ST Edge] DSC Security System / Envisalink Driver (2021)

Great to hear and thank you!

Todd,
Is it possible to make the alarm system driver a parent/child with all the zones as children?
For me that would put me well under the 200 device limit.

If smartthings was stable I could remove 3 virtual devices of my 203 devices if I had to onboard a problem device or update firmware, but not something I want to do daily or weekly, as on 48.3 I always have 5-9 Zigbee devices offline, and not practical for a person with even more devices than I have.

Has something changed? My understanding was that child devices still count towards the total number of devices, and therefore the total device limit.

I was lead to believe that changed with edge, my device count, both physical and virtual devices count matches your API browser -1, as it seems to include the hub. Which also matches the app’s count of my devices. If I added my multi-components devices children it would be significantly higher.

Maybe @nayelyz could comment on this?

Child devices count as devices if the have there own device tiles.

If they are just multi-component devices with no child device tiles they won’t be counted.

ANNOUNCING VERSION 3 OF THE DSC/ENVISALINK DRIVER

I’m pleased to make available the next iteration of this driver that includes several enhancements as requested by the community, as well as some fixes to known issues.

This is a NEW driver and therefore will not automatically replace your existing driver. This is so YOU have control over when to upgrade, since it will be disruptive to your existing setups. For example, when you are ready to move to the new driver, you will be required to create all new panel and zone devices. This will in turn require you to redo any automations you have.

Your existing V2 driver will continue to run normally and I’ll not even remove it from the channel for a few months. So you can decide when you are ready to move to the V3 driver.

Version 3 Enhancements

  • Clean-up of known annoyances in V2 driver (field labels, button issues, etc.)
  • Ability to initiate PGM1, PGM2, PGM3, PGM4 commands from automations
  • Fixes to instant arm commands
  • Partition status distinction between regular armed and instant-armed states (@7522)
  • Know who in the household last armed/disarmed the system
    • addition of last-armed user field in panel device; user names are configured in new device Setting option
  • Enhanced trouble condition information
    • addition of trouble type field in panel device to specifically indicate Battery, Bell, AC Power Lost, etc. trouble conditions
  • Improved notification and recovery of Envisalink connection loss
    • addition of periodic Envisalink connection monitoring: poll frequency in minutes can be configured in primary panel device settings; if Envisalink connection found not to be active, then all devices will be set to offline status and partition status set to ‘Offline’, enabling automation triggers.

Additional information is available in the driver README file on github.

A special thank-you goes out to @BobR for his ideas on enhancements and willingness to test the driver out before I released it.


Installation

Before proceeding, you will need to delete any existing V2 panel and zone devices, and remove the V2 driver.

You can install the V3 driver from my shared projects channel. Enroll your hub if not already, and choose to install the “Envisalink 3.0” driver.

For the remaining steps please refer to the README instructions.

If you follow my instructions carefully you should be back up and running within a matter of minutes (not including re-creating any automations you need).

3 Likes

My DSC system with EVL3 worked perfectly with your Edge Driver for a while. Unfortunately, a lightning took out most of my network items includes EVL3.
Just replaced it with EVL4 today and it’s running fine with EyeZ. However, I couldn’t make it work with my ST with your Edge Driver 2.1. Tried to uninstall Ver 2.1 and install ver3 instead but it says “Cannot uninstall because the driver is in use”. Can you kindly point me to the right direction: (1) what I need to do to make it work again with the current V2 driver, or (2) how can I move to ver3?

Thank you very much for making this available and taking time to help me. Have a great day!

That’s a major bummer!

Usually if you can’t UNinstall a driver because it is “in use”, it is because you haven’t deleted all of its associated devices. Make sure you first delete any and all panel and zone devices first. You can use Samsung account or API Browser+ to check for any devices assigned to that driver if you’re not finding them with the SmartThings mobile app.

But to answer your questions:

Hard to say what the problem is without seeing some driver logs, but are you sure you have the right password to the EVL4? The default is ‘user’, and don’t get this confused with the eyes-on password, which is something different. Also, since you had to re-do your network, be sure that the SmartThings hub and EVL4 are on the same subnet and that you have the right IP address configured.

I’d refer you to my post above and/or the README file.

Happy to answer any other questions or diagnose this further with you if needed. You may need to get the SmartThings CLI so you can get driver logs if you aren’t able to get things working.

1 Like

Many thanks for the quick response. It came back with your help!

As I mentioned, most of my network devices are gone. The UniFi router (USG) and all switches are gone, the new Eero mesh network gives out DHCP for my ST Hub. I did remember to configure the new EVL4 with old IP and did not realize I need change the IP for the Hub as well. As soon as I changed the Hub IP, it comes back! I can check the logs from CLI as well.

However, it seems there is some issues. For example, the Front Door shows offline on my ST app but actually changes its status when I open/close it. It shows normal on EyezOn as well.

If you are okay and have time, I will msg you instead of posting here for more details.

Thanks again for the kind help! Really appreciate.

Glad to hear you made progress. Regarding your front door device showing offline, let me know if that doesn’t clear up. Sometimes you get temporary glitches in the app that eventually go away.

Feel free to DM me if more help is needed.

Is any one having any issues with their EVL4, since 02/07 I have being having some network issues, my wifi and internet is going down, and therefore all smartthing devices go offline. All of my wired LAN functions, and the only thing I can see are are these logs from my network switch for port#8 which is connected to the EVL4.

|<182>1 2023-07-04T03:24:35.957-7:00Z 192.168.120.3-1 STP-6-PORT_STATE proto_stp.c(820) %% Port GigabitEthernet8 moving from Blocking to Forwarding
<182>1 2023-07-04T03:24:33.207-7:00Z 192.168.120.3-1 STP-6-PORT_STATE proto_stp.c(820) %% Port GigabitEthernet8 moving from Disabled to Blocking
<181>1 2023-07-04T03:24:32.957-7:00Z 192.168.120.3-1 TRAPMGR-5-PORT_LINK_UP ksi_snmp.c(232) %% Interface GigabitEthernet8 link up
<182>1 2023-07-04T03:24:30.457-7:00Z 192.168.120.3-1 STP-6-PORT_STATE proto_stp.c(820) %% Port GigabitEthernet8 moving from Forwarding to Disabled
<181>1 2023-07-04T03:24:30.287-7:00Z 192.168.120.3-1 TRAPMGR-5-PORT_LINK_DOWN ksi_snmp.c(230) %% Interface GigabitEthernet8 link down
<182>1 2023-07-04T03:24:05.957-7:00Z 192.168.120.3-1 STP-6-PORT_STATE proto_stp.c(820) %% Port GigabitEthernet8 moving from Blocking to Forwarding|<<

Looks like your envisalink board is rebooting or at the least, power cycling, hence why the link is flapping. Check your power connections to the alarm panel and ensure they haven’t come loose. Also check to ensure the Ethernet cable is firmly seated.

Also, ensure your board is up to date on firmware… I think mine is at 01.04.176.

1 Like

Hi @TAustin, I will start by saying thank you for all the work you put in for this community. Its much appreciated as I use a few of your very useful drivers.

On to my issue…

I switched a little while ago to V3 and I’ve run in to a situation where whenever I disarm my DSC system (through Smartthings, Eye-On app or keypad) the system rearms itself. If I try to disarm again, it arms again… the only way to stop it to open a contact (i.e. door) so that it fails to arm or I need to change the IP in settings to something invalid and use Eye-On app or keypad.

Any ideas on what I could be doing wrong?
Everything else works perfectly and didn’t have this issue with the previous version.
I prepared logs from CLI when this is happening if needed.
I have the Evl4 with fw 01.04.184

Thank you

If you are using presence in routines to arm the alarm, verify that your app actually shows all as present.

If you are using modes in routines to arm the alarm, verify that your app actually shows the correct mode.

Thank you, but does not seem to be the issue.
I do use presence to arm, but I’ve been using virtual devices (another great implementation from TAustin) as an in-between and I can confirm those routines are not being triggered.

That’s pretty strange! I assume you’ve made sure you don’t have some rogue routine still defined somewhere that could be triggering this behavior? Do you have the STHM integration turned off in the panel device settings (‘no auto-synch’)?

If you can get driver logs, that would be helpful. Send it to me in a direct message and I’ll see if it gives us any clues.

Yep, triple checked, also deleted everything today and reconfigured, no luck.
STHM sync didn’t make a difference when I kept it off after reinstalling.
I’ll send logs shortly, tx!!

After looking at the log you sent, I can see what is happening, but I’m not certain as to WHY it is happening…

When you disarm the system, as soon as my Edge driver receives that disarmed notice from the Envisalink, it performs a *1 keypad command, which is supposed to retrieve an update from your DSC of the zone bypass states. However what is happening in your case is that, instead of sending the zone bypass states, your system is sending a request for access code (no idea why). The driver receives that request, and dutifully sends the access code back. At this point, your system is seeing this access code as a new request to arm the system. Thus the re-arms you are seeing.

So this leads me to a couple possibilities:

  1. Your Envisalink firmware could be different or out of date
  2. You have some unique configuration programmed in your DSC that is causing this behavior

Let’s explore #1 first:

  • What specific Envisalink board do you have, and how old is your DSC system?
  • Can you check your Envisalink firmware version by bringing up the Envisalink web page, and click on the Network menu item in the top right. At the bottom of that page it should show your firmware version. (Mine is 01.01.108).
  • What happens when you press “*1” on one of your DSC panels? It should bring up a bypass menu.

Ok, I’m now out of town so won’t be able to fiddle much.

I have the Evl4 with fw 01.04.184
DSC Power Series 832 / PC5O1O (v2?) at least 15y old…

Looking at the installation manual and my programing sheets, the “Code Required for Bypass” should be off, but it should be on for UL listed systems according to the manual and now I don’t recall if I deviated from my programing sheets as the last time I reset/ reprogramed the system was 4 years ago…

When I get back on Friday, I will double check and try to toggle the setting and see what happens and report back.

Thank you!

1 Like

I just switched over to this driver a few days ago. Everything seems to be working fine so far except for 1 zone. It is a window sensor and it is currently open. In the eyezon app and the panel itself it is open and when I need to set the alarm I bypass it by either doing *1 15 or pressing bypass in the eyezon app. This driver however shows only - as the status, but I can press the bypass button which then sets the system in ready mode. Question is could installing this driver and setting everything up with the window open cause this issue? I have opened up windows and doors in other zones and it shows open and closed just fine.