[ST Edge] Driver for Intermatic Pool Control System (PE653/PE953)

I had problems with that first step too. I think mine said “unpair” or something like that and it all worked.

My SmartThings Panel in “favorites” started displaying status (iOS). But the status is often stale and does not match status when you click the panel to get into the detailed view. Not a big deal just FYI.

I modified my Automation of the buttons on the PE653. After a power failure the PE653 powers up with all buttons off. The pump remembers its last state before power failure. But my Automations turned it off when all buttons came up Off :). So now, if all buttons are off, my automation steps do nothing. To turn it off, If both Speed 1 (button 1) and Speed 2 (button 2) are ON I shut the pump off :).

So I have 2 bits for 4 states

10 = High Speed
01 = Low Speed
11 = Pump Off
00 = No-Op (don’t change speed)

This works flawless and almost instant. I can click the buttons on PE653 in any order and it always seems to do the right thing. I almost never need to pickup the PE953 which is primarly what I used it for.

I like to use high speed when swimming or adding chemicals to skimmer. Low speed 24/7 other wise. And Off when putting Solar cover on/off.

It’s programmed to go to low speed and turn on Circuit 3 for 15 minutes a day to add Chlorine to the pool. That also works flawless and the main reason I set this all up.

P.S. I always turn off power to the pump if serving the pump and not depend on automation to keep it off.

I send an SMS based on monitoring the 4 states of the two switches.

Sorry for the late response. I tried it again within a few inches and it was the same behavior. What would it take to get the capability based fingerprint working?

I’ve pushed out an update to the driver, which should hit hubs within the next 12 hours. If you have the CLI installed, you can also force a driver update immediately with smartthings edge:drivers:install. The new version is dated 2022-08-15T23:19:50.09859054.

New profile created - P_-SSSSS---WA_. Dashboard tiles for all profiles should now match the capabilities that each profile has. Hopefully the capabilities that I chose to display are useful ones.

This is now implemented. If you already have the PE653 joined with an Edge driver, you’ll hopefully now see the correct driver as an option to switch to in the app. If you do a fresh join, the PE653 will most likely join using the PE953 driver, and then you’ll need to do a driver swap.

Awesome work. Thank you very much. How do we at least send you a virtual beer as thanks for all this work?

It should have read do we have a way to at least send you a virtual beer :stuck_out_tongue:

I’ve just installed this Edge driver. Thanks for your great work on this! When I create Routines using the PE653, my only choice for Circuits 1, 3 and 4 is “On or Off” (I have a heater, so only 4 circuits). However, Circuit 2 gives me three choices On or Off, On and Off. Why don’t the other circuits have the separate On and Off choices? I really need them for my Routines to function correctly and to access the added Delay and Auto Off options.

If you’re using an iOS device then you’ve run into a known bug in the app. I can’t immediately find the topic where it’s been discussed, but it affects any multi-component device. You should go through the prompts in the app to report the bug to customer support.

If you have any Android devices then you should be able to use those to set up your routines, or I’ve seen people comment that they were able to use an Android emulator as a workaround.

Thanks for the very quick response! I am using an iOS device. I’ll try on Android. Thanks for the tip!

I just realized I probably wasn’t posting in the most pertinent thread, so at risk of cross posting, I’ll delete the other post:

I have gone through the instructions, Pairing, etc., and am having mixed results.
As someone pointed out, there are some inaccuracies in the pairing instructions which I will reflect my interpretations in the steps below:

  1. Loaded the edge drivers for 653 and 953 from the invitation page.
  2. on the 953 I chose remove device and hit the include button on the 653… success
  3. on the 953 I chose reset controller, reset network & config… success.
  4. from the ST app I clicked add device, then on the 653 pushed the include button… ST found the Intermatic Pool controller, added automatically, option to rename was present, I left it alone.
  5. on the 953 I chose Controller copy, receive network only… fail. After a couple minutes of “waiting for include” it finally times out with a “fail” message and returns to the default menu list. wash rinse repeat and no pairing of the 953.

I’ve tried subsequent steps with no success… battery removal, hitting the include button on the 653, etc… can’t get the 953 paired into the config… The ST app works to control the 653, pretty much. I say that as sometimes the circuit on button will spin for a long time with no relay click and I’ll get a network timeout error… but then after a minute or 2 the relay clicks… other times it clicks right away and the status is updated. Every time I go into the Intermatic device on ST I get “This device hasn’t updated all of it’s status information yet. Check again later”… this appears at other times as well while in the device UI.
This is on FW 3.4 on the 653 and the 953 shows a “34P” in the upper corner, which I believe reflects its FW.

Also I have the v2 hub about 1" from the 653 and the 953 during all of this.

I have created virtual switches for each of my implemented functions (Pool Pump, Pop-Ups, Water feature, Pool light) and they are all working via Alexa commands… just no 953 :frowning:

I believe that is the current way the app indicates that the device still has some null attributes. The app has a bit of a thing about those. It is quite common at the moment because the synthetic events that initialised the attributes on freshly joined devices have been temporarily disabled in the stock drivers.

1 Like

I’m having issues just getting the intermatic to pair, despite the hub being a few inches away from the 653’s antenna. Do you happen to know if there is a way to verify that the driver’s are loaded/enrolled on my hub?

When you click “Add device” on smartthings do you then select “Scan for Nearby devices”? Nothing seems to be found. This is on the iOS app.

Additionally, how do you determine the firmware on you 653?

Thanks in advance.


I was able to see that the 635 is showing as a device in “mydevices” with recent activity. I’m wondering if this is simply a result of adding the driver channel or if smartthings is indeed pairing with the 635 and I’m just not able to complete it on the ios app.

If you installed the drivers from the invitation page after being logged in with your hub name identified near the top of the install page, you should have the drivers at the ready for re-pairing the 635, etc.
I first deleted the Intermatic from my ST app… this can be done by hitting delete in that device and then pushing the include button on the 635… or letting the delete timeout and then click force delete. That way I know that the device is being included using the edge driver(s) and there’s no conflict with the old groovy version (this may not be necessary but it made me feel good). Then once the red light is blinking on the 635 (no longer paired) doing an add device in ST and then pressing the include button on the 635 again, mine connected all by itself. You’ll know that it’s using the edge device driver after it’s included when you are in the device in ST and click the 3 bar menu in the upper right corner, you will see a “driver” option. That only shows up for local edge drivers apparently.
Once in the device, which defaults to configuration mode, you should see the revision of the 635 listed.
The screen grab you included is from the (being) deprecated api graph user interface… seems we need to get used to not using that long term and just operate from within the ST app.

One suggestion would be to try going through the pair by brand prompts in the app. Scan nearby searches across zwave/ZigBee/LAN, whereas by brand can just isolate one radio. I usually select a GE zwave switch as the device I say I’m trying to join. That will put the zwave radio into inclusion - it won’t matter that you’re joining something other than a GE device.

That screenshot looks like your device joined. Look around in all your rooms in the app (particularly the room your hub is assigned to) or try the search option to see if you can find it.

From your suggestion, it sounds like you are pairing the 953 via ST doing an add device… whereas the instructions all say to not touch ST, but to select the choose Controller Copy option on the 953 and then the choose Receive Net Only option… then the 953 should report ‘Successful’ and possibly lock up requiring a battery pull to resume.
Is there another way to link the 953 as a secondary controller for the 653?

It’s two steps to get the 953 onboarded, that have to be in this order:

  1. Include the 953 to the ST zwave network.
  2. Associate the 953 with the 653.

The Controller Copy/Receive Net step is the equivalent of putting the 953 into inclusion mode. The 953 is a zwave controller though, so the terminology is different. When the 953 is in that inclusion mode you need to run ST inclusion. Looking at the instructions… there should be a step 8a that says to start ST inclusion again.

ok… I was thinking you were heading in that direction…and yes, then there should be a step 8a.
so I tried that… but I don’t know if I put the 953 in the right state to have ST discover it. How should I do that because I was able to get the 953 discovered in ST and it showed up using your driver, however it was in standby mode and the 953 wouldn’t display anything but “Out of Range” even though it was an inch from the hub and the 653… battery pulls didn’t help and I can’t get the 953 to respond other than display Out of Range, so I forced it into it’s menu (Enter + P/S) and selected receive net only and it fails after a time. So perhaps the 953 isn’t in ST the right way?
There must be a step/steps I’m missing.

Edit : re-reading I see you said to do the controller copy/receive net to prep the 953 for inclusion to ST. Ok… that’s what I did and had the above results.

I think Out of Range on the 953 might be because it wants to be connected to a 653. It’s been a while since I’ve done inclusion so just guessing. If you have the 953 showing up as a device in ST then you might be ready to move on to linking it to the 653 in step 11.

1 Like

WHOOOOHOO! You got it !!!
Ok… maybe an instruction update could add the 8a insert to specify adding the 953 to ST the way you said… then holding the Enter+P/S to get the menu back on the 953 and then do an Include device, press include on the 653… that did it!
Bless you, bless you, bless you!
Really appreciate the help.
In case I missed it somewhere is there a donation link for your work on this?
I still get the out of range initially, but after a couple presses of enter on the 953 it comes up with the 653 interface… this is how it’s always worked before anyway and I found that annoying, but at least it functions.

Suggested updated instructions:

  1. 953 choose Remove Device {clears the 653}
  2. 653 push Include button {wipes programming, Include light starts blinking}
  3. 953 choose Reset Controller, choose ‘reset network & config’
  4. From ST app choose ‘Add Device’ and scan
  5. 653 push Include button
  6. ST app should pair with “Added Automatically” and give option to change the name
  7. 953 choose Controller Copy {another non-intuitive step, this adds the remote to ST}
  8. 953 choose Receive Network Only
  9. From ST app chose ‘Add Device’ and scan
  10. 953 should report ‘Successful’ and may lock up. {really! at least on the software rev I am on, I think v3.1}, if it doesn’t lock up, press and hold Enter then P/S in order to display menu on the 953, If it does lock up, remove and replace battery then press and hold Enter then P/S in order in order to display the menu on the 953.
  11. 953 choose Include device.
  12. 653 push Include button {one more time!}
  13. 953 should report ‘successful’
  14. Voila!
1 Like

Sorry bothering you…you have done so much already, but I am new to Edge (used the old drivers so far) and can’t do much myself yet. I tried your Edge drivers and I paired my devices successfully. However, it looks like there is no profile for my configuration. I have pool/spa combination with one single speed pump controlled by circuit 1 (power on/off). I have my heater connected to circuit 5. I am using “water feature” (P5043ME) for spa spillover control which is on circuit 4. The rest of the circuits are lights and blower (I have separate z-wave switch to control vacuum). So, it seems my profile should be either PS-SSSSS-_-H-WAS or PS-SSSS_-_-H-WAS. I tried PS-SSSSS-V-H-WAS with single speed pump selected in the configuration. It still expects VS pump. But the main problem is that the spa shows as on when the circuit 4 (water feature) is on. Seems that the configuration with P5043 is not detected properly… Any recommendation on how I could improve the situation would be very appreciated. Thanks

If I’m understanding your setup correctly, then this would be the profile you’d need. I can add one for that.

I don’t have a P5043ME so I’ve replicated the handling for it that was in the DTH but haven’t been able to test. If you’re able to grab logs while toggling the water feature on/off and while toggling pool/spa mode then that would help diagnose the issue. Post logs here in a code block by putting ``` on a separate line above and below the logs.

Thanks for the response. I will generate some logs.