[ST Edge] coroutine.yield error

Hi,

Anyone is familiar with the following error message?

2022-08-24T18:09:22.759225400+00:00 FATAL Zigbee Multi Gang Switch [YG] v2.1.3  RPC Status: status: Internal, message: "error in scripting-engine broker", details: [], metadata: MetadataMap { headers: {"content-type": "application/grpc", "date": "Wed, 24 Aug 2022 18:09:21 GMT"} }
Traceback:
stack traceback:
        [C]: in function 'coroutine.yield'
        [string "coroutine"]:9: in function 'wrapped_coroutine_resume'
        [string "cosock.lua"]:265: in field 'run'
        [string "st/driver.lua"]:739: in method 'run'
        [string "init.lua"]:204: in main chunk

Happened when installing a new driver version.
Thanks

Hi, @ygerlovin
Are you using the 44 version of the Hub’s firmware?

I already asked the team about this, but I wanted to check this detail with you :smiley:

@nayelyz

44.00009

@ygerlovin, following up on this case. When you mentioned “installing a new driver version”, did you mean you were discovering the device again?

I just saw this error but I deleted a driver package and was discovering the device from another one…

Hi @nayelyz ,
Thanks for following up.
I think I packaged and installed the new version of existing driver on my hub.

I’m sorry, I’m not sure what exactly was the reason for the new version, I could be scanning for the new devices before that, I remember making a typo in fingerprint. So it could be scanning, fixing and then installing the new version.