[ST Edge/Beta] Xiaomi/Aqara/Tuya zigbee sensors driver

OK, no worries. I took out the batteries and put them back after updating the drivers and they’re all working now

After doing this, it should start working. If it doesn’t, take out the batteries and put them back in.

I’ll second this request @ygerlovin . I have a ton of these original Xiaomi motion sensors, model RTCGQ01LM. Would love a driver for them before time runs out.

@paulmike3
You are welcome to try the latest version and see whether it works for you

I’ve got a Xiaomi door sensor which looks like this one, but I can’t find any details of the model now.
It works fine with Smartthings and my DTH except to pair it you have to find the catchall then enter the network ID manually.
It seems even with this app it can’t find it normally, is there a way to test it by forcing the ID or is this not possible?

1 Like

Hi!

I have the exact same issue with two of my devices:
Aqara Door Contact: MCCGQ01LM
Motion Sensor RTCGQ01LM

When I search for these two devices, I can see the catchall in the Hub Events but the search fails. Nothing is found.

On the other hand, I’ve used the same procedure for a Water Sensor and it worked so smooth.
What I am doing wrong here?

I have this issue and nothing I have tried keeps the Aqara motion and open/close sensors working for any length of time. Even after removing the driver it stays at 1.8.14.

@NickA

I’m not sure I understand the issue you are facing.
Do aqara motion and door sensors work initially, then after a while stop working?
Please provide the logs from the driver.

What do you mean by that? If the driver is removed, where do you see its version?

[quote=“[ST Edge/Beta] Xiaomi/Aqara/Tuya zigbee sensors driver, post:351, topic:234709”]
Try to remove the driver without removing the devices to force the update.
[/quote]

I have done this and the driver remains at 1.8.14, the version number is from the app.
I have just rebooted my hub and included them again, I have had multiple issues since Thursday, not just with my Aqara devices but also my DSC alarm, [ST Edge] DSC Security System / Envisalink Driver (2021)

So I suspect it is possibly more app related. Smartthings has consumed too much of my time this week so I will be giving myself a break from it until later this weekend.

That’s the good version don’t try to have 1.8.13 , if I understand well it’s what your looking for

Dear all,

A quick reminder to everybody on how the Xiaomi Aqara devices works, this is general for the three types I have (temperature/humidity, door/window, and motion/light):

If you quick press the button they will respond in the follow way:
A. No connectivity: 1 blink to confirm you pressed, then one blink
B. Connectivity: 1 blink to confirm you pressed, then two blink
C. Re-linking: 1 blink to confirm you pressed, then three blink

I you hold the button in for 3-5 seconds, it will reset and re-link and blink 3 times. Keep holding while it blinks. I guess many are using this function incorrectly, see below.

Now, I have had the bspranger DTH groovy drivers installed for years and I admit the Xiaomi devices need to be very close to the hub or repeater to function - else they disconnect.
I was connecting the devices the old school way, indicated by @Gavin_Melling using the ID in the catchall statement and then manually creating a device and typing the network number - because the Xiaomi devices really dont want to connect - until now with the new EDGE drivers, see below, it apparently has become easier.

I don’t follow the community often, but I got very surprised to see the Groovy DTH disappearing and now we need to use EDGE drivers. Anyway, after some digging its clear. To enable the drivers you have to delete your old devices in the hub. Yes, I tried to switch type in the online Smartthings IDE, but don’t, you cannot get out of deleting them. And by the way, use the online IDE to delete the devices because if you use the app, they still remain in the online IDE, and when you start re-linking the devices, they will come back with the wrong driver.

When the old DTH and all devices are deleted, then link the EDGE driver here, to your hub:
https://community.smartthings.com/t/st-edge-beta-xiaomi-aqara-tuya-zigbee-sensors-driver/234709/373

I had to connect a few times until the driver was really accepted.

To re-connect your Xiaomi devices I made them connect by doing the following. Just remember I was also really worried like @Gavin_Melling and @Sterian_Vlad in terms of never getting my devices flying again.

I. add device with click on “+” in the app, and follow the normal procedure. You can use either the general search or use the procedure defined by the device by choosing the brand name Aqara.
II. Now, when the search for new devices is ongoing, you cannot just do like the old days - using short click to get the devices connecting. You have to do a long click to reset.
III. Then keep short clicking with a few seconds pause, to see the message from the device every time. Despite the blinking tells you that the device is re-connecting (showing 3 blinks every time) continue short clicking. After some clicks you will see a kind of long blink which is really 3 blinks on top of each other, then stop clicking, this is when the device is really connecting. It varied a bit how many times I had to keep short clicking but anything from 2-20 times. Which means I had to restart addition of device sometimes when time ran out - and I had to start again with a long press to reset again. This I had to do 1 out of 5 devices. The reason is most likely I didnt start quick pressing quick enough after the first reset.

My worry is now gone in terms of the catchall and manual addition of Xiaomi devices. I appreciate that the 1.8.14 driver I tested, works, and that the Xiaomi devices have a functioning Edge driver.

4 Likes

Hi @PLFosboel !

Thank you for your detailed instructions. Seems like I was doing it in an incomplete way.

I’ll give it another try tomorrow.
Btw, meanwhile I have manage to add two new more aqara devices without issues: AirQuality monitor & Temp / Humidity sensor. Both of them work very nice :grin:

Dear all,
I will be on vacation with limited connectivity till the first week of Oct and will not be able to answer your questions or requests.
Thank you for your understanding

9 Likes

Yakov, Have a great vacation!

Update:
@Sylvain pointed me to a driver for the sensors here:

Thanks a lot!


I am looking for a driver for the Xiaomi Aqara Leak Sensor. It is the round type sensor. Here is what I get from the SmartThings Groovy interface:

  • zigbeeNodeType: SLEEPY_END_DEVICE
  • application: 04
  • endpointId: 01
  • manufacturer: LUMI
  • model: lumi.sensor_wleak.aq1

The original DTH I am using was published by bspranger.

It looks like this one on Amazon, but I purchased mine in June 2020 on aliexpress

Here is the link to the sensor I purchased (from my order history), it says it is no longer available, but the model number seems to match what is in the link at Amazon above.

It would be great if I could continue using these sensors in the future.

Really appreciate all your work, and of course I would be happy to test any version you create!

Andreas

Look for @Mariano_Colmenarejo is as the driver for you, I have 2 of those working with is driver .

Search for
ZigBee aqara water leak mc

3 Likes

Thanks for the reply. The latest version does seem to work OK for these Xiaomi motion sensors, model RTCGQ01LM. That said, voltage/battery might not be reporting correctly. Mine have 4+ year old batteries and they’re reporting 3.0 V and 100% battery. Surely they’re less than that, but I’m not overly concerned with battery accuracy myself.

Thanks again for your efforts getting these devices working with the new platform. Much appreciated!

I used to think this was the solution, but then I found something else out… The Xiaomi devices cannot connect to your hub via a Zigbee repeater (Edit: most Zigbee repeaters. See below). Meaning, they must connect directly to the hub initially. If they do connect via a repeater, they drop off after 1-2 hours as they are the “weird” zigbee protocol (sorry for my lack of technical details there).

I found that when I need to pair a new Xiaomi sensor, I must unplug any powered Zigbee repeaters I have (Zigbee on/off plugs but anything Zigbee plugged into the wall is a good rule of thumb). Once the repeaters/plugs are out of my Zigbee mesh, I have had 100% success keeping the Xiaomi sensors paired, regardless of how far away from the hub I am when I first connect them. I’ve paired from 4 rooms and 2 floors away from the hub, and as long as the Zigbee repeaters are out of the mix for the first couple hours of their stabilizing, they stay connected for years.

Hope this helps someone get and keep these awesome devices connected!

1 Like

To be clear you are talking about Xiaomi exclusively and not Aqara also right?

I have 14 total Aqara sensors registered to SmartThings all leveraging Edge drivers coded by this community. Of the 14 sensors 7 are contact, 3 motion including a P1, 1 smart plug, 1vibration , 1 temp humidty and 1 water leak. Of that break down I have connected 5 of the sensors through Ikea Tradfri Smart Outlets. These 5 were located at the very edge of the Aeotec v3 hub and its Zigbee network .Pairing sequence was Ikea plugs to hub, move plugs to edge location and pair sensors there.

I can’t say for sure, as I only have the OG Xiaomi sensors (motion and door). It’s possible that the Aqara handle the Tradfri outlets better. In fact, I also have at least 2 of the Tradfri outlets around my house, and have not unplugged them when pairing my Xiaomi devices, and they have paired fine. So that seems to indicate either A) they aren’t pairing using the Tradfri plugs, or they are and Tradfri isn’t interfering the same way other Zigbee plugs historically have.

The specific Zigbee outlet that I know breaks the stability of the Xiaomi devices on my network is a Sylvania Smart+ model 72922-A. It’s 100% responsible for my previous pairing and stability problems. I figured it out years ago when the ST IDE started showing the path back to the hub. Any that included this plug after pairing fell off. I also know others struggled with other brand plugs doing the same over the years.

I have the v.2 ST hub, so also I suppose there could be a slight difference with what hub you’re using.

Thanks so much for the link! I added the sensors and they’re working great