ST door/window sensors keep disconnecting

I’ve dealt with this issue for years now. It is not a battery issue. I don’t think it is a range issue since other Zwave devices including repeaters are in the vicinity of the sensors I have issues with. It’s always the ST door/window sensors that keep disconnecting. Not all of them, just, well, like three in particular. I rotate them to other spots in my house and re-add them frequently. It’s definitely not the battery. These were the early ST ones, the more square ones. Any ideas besides replacing them? And, under the new app, is there an easy way to resync them? Currently I’m deleting them and adding them as if a new device. Thanks all!

St sensors are Zigbee not ZWave so it is entirely possible you can have a Zigbee signal issue right next to a ZWave device functioning perfectly well in the same exact space. So first, how fsr away are they and second do you have any zigbee line powered devices? Finally, Zigbee coexists in the 2.5 Ghz wifi space. Did you recently have any Wi-Fi changes?

1 Like

Thanks Nathan. Are all of their ST multisensors Zigbee?

I do not believe I have any Zigbee line-powered devices, only Z wave. This sensor is about 35 feet from the hub. I have not changed anything with my wifi.

Thank you,

Smartthings branded devices are all either Zigbee or some of the newer ones are WiFi… I know for a fact they aren’t ZWave

Thanks. All of my sensor issues appear to be Zigbee then. Any ideas how I can improve my sensor? Is it too far away?

Alternatively, any recommendation on another zwave sensor?

It COULD be… It’s hard to tell. The SPEC says ~100 ft. and even farther with zigbee 3 but honestly I’ve never got that range with either Zigbee or Zwave. I use 25 ft as my radius between repeaters in planning my installs because 50’ is the farthest I’ve ever been able to get in my home (because walls and nails and stucco and nails are a thing.) so I cut that in half.

What’s more likely to help immediately - lets see if Wifi interference is hurting you. Wifi and Zigbee share the same RF space - @ 2.4 Ghz, if they conflict, Zigbee ALWAYS loses, because physics.

First thing I would check is the placement of your WiFi gear v. your ST hub. or alternatively that sensor. Step 1 - get the Wifi as far away from the hub (or that sensor if it’s close to that) as you possibly can.
Step 2 - Check what channel the 2.4Ghz band of your WiFi Gear is using, then check the hub in the IDE and see what channel your ST hub is using. (Check Smartthings hub at > My Hubs and then scroll down to the Zigbee section.

Wifi channel does not equal Zigbee channel - use this as a translator:
[ZigBee and WiFi Coexistence — MetaGeek]( if you have overlap - move the Wifi Channel to one that won’t conflict. Fir instance if your wifi is using Wifi 11 and your ST hub is on ZB 19, they’re conflicting.

If you do that restart the hub then the device and see if it comes back and stays. If it doesn’t you’ll need a repeater.

Let us know what you find.

Thanks Nathan. I’m afraid moving the wifi farther than it is from the hub will be difficult as they are both on hardwires, but the one is on the opposite side of the room from the other.

I’m finding the hub is on channel 14 and the wifi on channel 3 (sending both a 2.4 and 5.0 GHz signal).

I read the link. We have a bath of wifi signals all around me, as I’m in a metro area. :frowning:

I’m using the hub v2 if that matters (i.e. if v3 has a stronger zigbee signal).

After reading the article, my first though was to put the Zigbee channel to as far right as possible. I selected 24, and before I could confirm, the ST graph API website popup gave this warning:

“Changing the Zigbee channel can be useful for avoiding interference. Before continuing, make sure that all the devices are powered on. Some devices including the first generation SmartThings sensors will need to be factory reset and rejoined after changing the channel if they stop working. In addition, some of the first generation SmartThings sensors will not work on channel 11 or 25 so do not use those channels if you have any of those devices. Changing the channel will take about 10 seconds. Are you sure you want to continue?”

I declined for now. I think some of my sensors are indeed first gen ST sensors. Any idea how to confirm this on the sensor itself? I’m at Channel 14, so I’m already in that range. But the same sensors seem to be the ones that cause problems, so while they work for a time after I reset them, they tend to be the same ones that always drop off. I wonder if this is the right lead for this mystery…

I think I have what are first and second gen ST sensors. The first did not have a reference to Samsung, the second did, but otherwise appeared the same. Maybe I’m mistaken, that these are the same gen with different packaging. In any event, all of these sensors are NOT the latest ones that are rounder. Mine are the original rectangular ones with rounded corners. I have the boxes for all.

I appreciate your patience and dialogue with me.

First no. Do mot change the hub zigbee channel. There are a lot of caveats to it. Changing the Zigbee channel on it is a brand new feature enabled by the 39.x firmware and a lot to learn before you mess with it. It might make things worse…

In your case id recommend a few strategically placed repeaters. Ikea and Peanut pocket sockets (both are reasonably priced) work well for this.


Need to build your Zigbee mesh.

1 Like

Thank you, I placed an order for some repeaters. More to come…

I have two different zigbee outlets in place now, one is the securifi peanut as recommended, and one is a innr. Both run locally, and both state they act as extenders, and both are rated well on Amazon. I’m testing. I’ll see how it works out and report back.

Do I need to do anything software wise or otherwise to rebuild the mesh? Or is must adding repeaters all I need to do? (I seem to recall a rebuild button in the old app, but see not such option in the new one.)

Thanks again!

Another observation: I see the sensors in the garage are routed through the peanut, great! However, oddly the one in the kitchen, which is closer to the hub than the garage, is also routing through the peanut in the garage. I put that innr brand one in the kitchen and the sensor did not attach to it. Is there a way to get it to connect more efficiently through the nearby extender?

No. Let the network do what its going to do - dont bother trying. It will end in tears…

If its working leave it alone.

1 Like

Thanks @nathancu