ST App on Android not showing push notifications on 1 phone

Having a confounding problem on ST NewApp – push messages are getting logged in the app have just stopped appearing on just one of my Android phones - Galaxy S20 5GUW running Android 11 with One UI 3.1. Notifications are on in the ST App and in the App Permissions. Forced stopped, toggled notifications in app and permissions, even rebooted the phone – no change. This one phone refuses to show notifications from either ST Automations or Webcore in any location (I have 2).

Any ideas (prior to remove/reinstall which I’d rather not have to redo my presence sensor)?? THANKS!

recommend uninstalling, rebooting device, reinstalling (which you are hesitant to do)

What are you, a shill for front line ST support? LOL!

OK I did it for you exactly as you said, uninstall, reboot, reinstall (fortunately it didn’t bonk my presence device in WebCore). I even tried the prior version APK sideloaded.



Try to edit the automation you use with those notifications and save the again. I just add a space at the end of the name and hit save.

The automations are logging Push Notifications to Messages – I am just not seeing the popup on my Android phone.

I tried as you indicated saving a ST App automation, and also added a SMS text message. I get the SMS, just not the push, and can see the message logged in the app, and the push is received on my wife’s phone (Android 10 Galaxy S9).

Ok try to go to settings apps and set smartthings to never go to sleep

That was already set, it seems to be default.

Oh my god, I’m think there really is a problem. I just created a topik for the same problem having not seen this.
Identical situation but smartphone Oneplus 6T with Android 10 , ST same app,
already try to cancel reboot and install ST app. No change, all my notification not work.

I am not getting smartthings notifications either for the last couple of days. Running S20+, Android 11, ST

I got a Samsung Push Service update today, hoped that would help. Rebooted even, no change. Last date I received a push notification from the ST App was Saturday 5/8.

1 Like

Sorry Bro, do you have test the win10 app ore Web beta app? :thinking: I yes, and I have this problem.

Interestingly, speaking of Win 10, I did just on Saturday night, download the Win 10 SmartThings app to my PC. I do not see notifications on the PC, either, although there seems to be a setting that implies I should see notifications. Anyone else start having problems after trying the Win 10 ST app?