ST and Fibaro FGS-221 Double On/Off Relay Switch

(Joe) #1

Purchased the UK ST yesterday after having a US version that was incompatable with my Fibaro devices. The FGS-221 is all wired up but the ST cannot pick this up. Alot of instructions about a B-button but no instruction on where that is on the relay, I’ve just assumed it was the reset button. Anyone had these issues or the ST just problematic ?

(Bob) #2

The picture in the instructions supplied with the sensor should show where it is.
I have a 212 but without climbing on top of my kitchen cabinets, I’m afraid I cannot tell you where it is.

(Joe) #3

Cheers Bob, but no mention of where the b-button is in the manual or online.

(Bob) #4

If you search for FGS 212 on line, it shows the button in the pdf. From memory it is a small hole that you use to reset.

(Joe) #5

Thanks Bob, thats the one I’m using so.

" press the button of the device or the push-button B located inside the housing of the switch relay
three times during 1.5 seconds. The LED will become green for 3 seconds and then turn off. The device is
now ready to work"

No Green light or any light on mine. Does the documentation refer to the controller or the device.

(Bob) #6

When you press the button, can you feel it ‘click/operate’.I could not on mine.
I gently opened the casing and the plastic ‘flap’ above the button didn’t seem to push the button on the pcb.
I had to do mine directly on the pcb to get it to associate and then I put the case back on.

(Joe) #7

Hi Bob, I can feel it but because its wired up, I can also see the lights switch on and off when resetting.

(Bob) #8

Not sure what to suggest.
With mine I opened the app on my phone and set it to ‘connect new things’ pressed the button 3 times and it associated OK.
My dimmer was about 10 metres from my hub. Perhaps yours is too far away.
In the instructions you can also press the button with a certain sequence and the dimmer will tell you how strong the signal is. Mine was green. I suppose this is only after it has associated though.

(Jason) #9

I dont have this device, and you may have already tried this, but have you tried doing a zwave exclude on the device?


Hello @oddbin, I have 4 of those relays in the UK.

Yes the “B” button is the small round reset button on the relay! I have had the very same problem that you have, where the relay can’t be found.

Things to try!

The relay may need a full reset. To prepare for this, I made sure nothing was connected to the connector terminals other than mains voltage. I basically wired up a mains cable to the relay and plugged the relay in the wall, within a few metres from the hub!

To master reset, you turn OFF the relay. Hold in the RESET button, and continue to hold whilst you turn the relay back ON. After about 3 seconds you will hear the relay contact click, which indicates that the relay has been reset! Now release the reset button. Turn OFF and ON the relay before attempting to pair again.

I have also found that slower presses of the reset helped to pair (1 click per second) for 3 presses, at other times it would be 3 rapid presses within 1 second.
When attempting a new pairing process, I would turn the power off to the relay, then back on again before retrying a new pairing session!

A couple of times, I have found that the relay was actually paired, and added in the ST list of THINGS in the APP, as “Z-wave” or “Fibaro Relay”.
When trying to pair, the relays were actually paired without the ST software actually acknowledging that it had found the relay (I do not know if this is still the case on the current software!)

Other things to try!

Hub z-wave repair.

Hub reset, remove power and batteries for 15 minutes!

Good luck!

(Joe) #11

Response from ST support

"I am really sorry but I will have to disappoint you. The smoke detector you have is not compatible due to the Z-wave architecture Fibaro have built into it. There are 2 models available the 001 and the 002, whilst the 001 is not compatible the 002 is (confusing I know). We also don’t currently support multi-channel devices such as the fibaro-fgs-221-double-on-off-relay-switch, and this would require a custom code to get it to work… As it is a dual switch you may only be able to get one of the switches to work.

The best place for getting the custom code would be the community, we have many of our programmers and engineers working along side fellow SmartThings users with custom integrations and automations. I have provided you a link to our UK compatibility list as well as the community."


You will find the dual switch device type below!