Smartthings, Webcore, Routines, and Google Home Assistant

Please help me figure out what I am doing wrong here.

I created a virtual switch in Smartthings and I am using it in WebCore to perform a number of things that I am calling “Good Morning”. I can run the switch from the Smartthings app just fine. I told Google to sync devices. When I tell Google Assistant “Hey Google, Good Morning” it doesnt run the piston I created in WebCore but gets confused and runs the default Google Assistant routine named Good Morning. I have the same thing setup for “Good Night” and it works just fine.

Is there anyway to tell Google Assistant to not run its routines but use the action from Smartthings?

Hope this makes sense.

Thanks,
Jason

Naming is always an issue.

Can you rename the switch and add it to the default good morning routine?

When you are saying to add it to the default good morning routine, would that be a routine in Smartthings or Google Assistant?

Sorry, but this is my first attempt at setting up routines that are powered through WebCore.

Try saying Hey google TURN on Good morning as its a switch, if you just say good morning to Google it will
run it’s own morning routine.

I discovered last night that if I said “Hello Google, run Good Morning” then it would run the routine. Is there a way to set this up so I dont have to say “run”?

I have only been able to that with IFTT, I can say hey google netflix and it turns the tv on and netflix. without saying run. But I could be wrong.

Can you add the Virtual Switch to the Google Good Morning routine?

1 Like

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.