Smartthings stopped responding to minimote buttons

Sometime in the last week or so, the actions I have set up for my Aeon minimotes stopped happening.
I have the Button Controller smart app set up to use the minimote to set Night and Home modes. In the phone app, I see the “button X was pressed” entry (twice, every time) on the “Recently” tab for the device, but the mode does not change.
I have gone through the settings of the Button Controller app to make sure they are set up right, and saved the settings. It has not made a difference.

mine seem to be working fine still. Did you try excluding it and re-including it? (unfortunately you’d have to re-do your button controller smart app configuration)

I just noticed that the button I have assigned to toggle a light on and off works fine. It’s just the buttons that are supposed to run Good Night and Good Morning that don’t do anything.
I can’t see how exclude/include would make a difference. The hub is obviously seeing the button pushes, because, as I said, they show up in the log.

1 Like

Depending on what hub you’re using, it could be related to this:

Same issue here… Four minimotes, all useless since a button now triggers two presses in smarthings.

We are looking into this issue.

1 Like

I noticed today that buttons (ST) and minimotes (Aeon) stopped working today. There was a hub update yesterday, but they worked after that. It appears that something is up with the Automations > Smartapp > Button Controller.

Another data point for this issue. The buttons sometimes do what they are supposed to. Usually, I can press the button repeatedly and it will eventually work.

Monday afternoon a change was made to address this. Are any of you still seeing an issue with your minimote?

1 Like

My minimotes have started working again.


Yes, working again here as well. Thank you!


I’m having a very odd problem with my Aeon Minimote model DSA03202W-ZWUS which I just moved from another location.

I factory reset the Minimote, and it appeared to pair correctly. All four buttons show in the app. When I push the buttons, the corresponding button in the app shows “Pressed” and the yellow indicator lights.

However, Button 1 runs the action assigned to button 2, and vice versa. Actions assigned to buttons 3 and 4 appear not to run at first, but the next time you push a button associated with the device, the action will run instead of the one assigned to the button you actually pressed.

This really sounds like the DH is not reading the button presses correctly. Has anyone else seen this behavior, and if so, how can it be corrected? @Brad_ST , any advice?

[Edit] Smart Lighting SmartApp to the rescue (this was my wife’s Minimote) - Smart Lighting reads the button actions correctly. So, it appears the problem is just in the Minimote handling in the UI.

1 Like

People have been reporting this issue with other handheld button controllers, including the Ikea and Xioami, if they were attempting to set up the actions from the device screen. The buttons are just numbered incorrectly. But if they set up rules for the same device using the automation creator or smart lights, everything was fine.



I’m having the same problem with the Aerotec MiniMote
Buttons do not map correctly. Is there a fix for this?
It worked fine in SmartThings Classic. Maybe a driver issue?

Are you on iOS? There’s a bug with quick actions in iOS. Try creating an Automation for the button presses instead.

Backing up what @Automated_House advises. I don’t even try using the native MiniMote configuration since it causes SmartThings app on Android all sorts of issues. But I use Smart Lighting instead because I’m using a device handler assigned in the IDE that allows the minimote to run as a local device, and since Smart Lighting also runs local, I can push a button on the minimote even when the SmartThings Hub is not connected to the internet and the Smart Lighting Routine runs the button action. It just happened the other morning when the internet was down and the SmartThings STHM was still Armed. I simply pressed the minimote button and it turned off the virtual switch that runs an Automation that Disarms the STHM.

Wait! What??? I just realized that it ran the Automation while the Hub was supposedly offline so I guess they now have Automations running local now??? It could be that the internet came back up at the same time though maybe…hum…