Smartthings plug and power meter kWh

Ahh I see what you mean.
But it doesnt matter for me, it works now! thank you so much, you are awesome! :smile:

1 Like

Any chance for this one?
It doesn’t work with your driver and the smartthings driver shows wrong consumption.

This device was added to the driver a long time ago and should work.

What is not working for you?


I can select it as a driver but neither the switch button nor the metrics work. Metering just displays the last state when i switched from smartthings switch driver

Did you try pairing it directly with the driver?


I deleted the device from smartthings and then re-paired it with the scan nearby method. It found the device and I could edit the name and add it to one of my rooms.
I check the driver and it shows as Zigbee Switch Power Mc

On the tiled screen it shows up and shows as connected with the ability to press the power button. However when I press it it shows a revolving line around the button for about 10 seconds then nothing happens.
When I tap into the tile it says “The device hasn’t updated all of its status information yet. Check again later”.
I see every field without any information. Most of the fields have a “-” in them. The power button is greyed out.
Refreshing doesn’t do anything
When I manually toggle the plug nothing changes in smartthings.Power button still doesn’t work and everything inside the tile is still the same.

Similar things happen with your Zigbee Power/Meter Mc driver.

When I switch to Zigbee Switch driver from Smartthings, everything works but the energy consumption is like 2MWh which is crazy.


I have the impression that the driver has not been installed correctly, this has already happened on some occasions after a firmware update ir hub reboot. I don’t know if your hub has been updated to beta 51.2 lately.

Try rebooting your hub or deleting driver from your hub and reinstalling it from my Channel


Hub version 000.050.00010

Reboot didn’t help. Driver reinstall helped.

Thank you!

1 Like