SmartThings Multipurpose Sensor Battery


(JP) #27

I worked with David from ST support on chat. He had me do a reset on my ST multi that was only showing temp and that fixed it right up. Below are the steps for anyone else seeing this issue. Now to hopefully fix my other ST multi with a new battery.....

Zigbee Device Repair (will not lose settings or Smartapps device is linked with)
Bring the device within 5ft of the hub

Remove the Cover

Carefully Remove Battery

Put the hub into "Join mode" from the SmartThings Mobile App

Tap My Home
Tap Things
Tap Connect New device
Screen will now display "I'm looking for your new things"
Press and hold down the white button

Reinsert Battery while holding down button

Once battery has been reinserted the LED light should flash, when it does release the button

Once released the device will now pair to the hub

The Mobile App will not indicate a new device has been found, because all we have done is reconnect a device that is already listed on your account.


(Wayne) #28

Just want to add that I edit a copy of the smartthings device handler and add a heartbeat event every time the device talks back to the hub. Then use simple device viewer to monitor and report any device that does not report events for over 2 hours. Using this I've not had any sensors fall asleep without me picking up quickly.
I do this for all of my devices.


(JP) #29

Want to share :wink:? I like that idea since clearly we cannot rely on battery % checking apps/ rules.


(Wayne) #30

Very simple change but I've put it here if you want to use it. Especially useful for sensors which have very little visible activity. Eventually this change will be obsolete and not necessary once we are able to access the healthcheck feature in the app. Until then it's essential in my view to obtain maximum benefit from the monitoring smartapps.

https://github.com/a4refillpad/temp


(Lenny) #31

Decided to check all 6 of my multisensors and realized 3 of them to be unresponsive. One being on my front door. I took the cover off and rolled the coin battery around a bit and it became responsive again. The two others, on my porch windows, were unsuccessful. I was able to repair one of them, the other is completely dead. I have a ticket in with support for a resolution. But this is completely unacceptable. We should be notified when a sensor is about to die or dead. We should not have to constantly check up on these every day or so. What's the point?

Does anybody have a solid alternative for a door/window sensor that sends you alerts about battery dying or dead? I would like to replace my multisensors.


#32

@LennDel I am running [RELEASE] Configurable Low Battery Notification and Device Monitoring from @rboy pay site http://smartthings.rboyapps.com $25/yr or $35/lifetime. His DH/apps are well worth the money!

Also, since Im actively working my ST daily I check the web IDE devices listing to see if and devices havent checked in lately.


(Lenny) #33

@Awestun This sounds interesting.. I just private messaged you for more info.


(Wayne) #34

I would simply use @krlaframboise’s awesome Simple Device Viewer to keep all your devices in check. It can also send battery notifications and alert you when devices are no longer active.


#35

@a4refillpad yep, that is another one that I use, but the problem that I run into that one is that i have over 60+ devices and it times out before the DH can poll and get a response back from all of the devices. This is a ST time out problem and not the DH itself.


(Kevin) #36

I built in a workaround for that problem in version 2.2.3 so you shouldn't be seeing timeouts anymore.

The SmartApp starts checking and if it can't finish within 15 seconds it stops where it is and picks up from where it left off 1 minute later.

Once it makes it through all the devices it goes back to running at the usual scheduled interval.


#37

@krlaframboise When I pulled the newest version down from github it was 2.3


(Kevin) #38

That's correct, the latest version is 2.3.0 and it was released last night. I mentioned version 2.2.3 because it was released back in September and should have fixed those timeout errors.

Let me know if you're still seeing timeouts with the latest version.

Just to clarify, this SmartApp doesn't poll the devices to get the last event time, it retrieves it from the device events table of the database.

The SmartApp has an optional "poll" feature which executes the poll command of the supported devices, but that feature should only be for devices that don't checkin on their own.


#39

@krlaframboise I see the "Unable to load the states..." message now with 3 listings under it. Should I let it on the screen for 1 min or go back to the main and run last states again and itll add to the previous?

also, now it is showing my sirens in switches even though they are added just to sirens.


(Kevin) #40

This problem has been fixed in version 2.3.1

The "Choose Devices" page lists all the capabilities to ensure you'll be able to add all your devices, but which field you choose the device from has no affect on which page it appears on. (lights are the only exception)

All devices that support the switch capability will appear on the Switches page. If you don't want your sirens to appear on the switches page, go into the "Display Settings" screen and exclude them for that capability.

I know that seems kind of strange, but excluding a device that appears somewhere you don't want it is a lot easier than selecting every device multiple times to get them on all the screens you do want them.


(Wayne) #41

I've got close to 200 devices and I have no issues using this app.


#42

@a4refillpad are you able to run a 'all devices - state' and see all 200 devices.


(Wayne) #43

No I've never use that option. I use the All devices - Last Event, the dashboard and all it's threshold notifications. I also see no point in adding all 200 devices, I mainly use it to monitor all my battery devices which is in excess of 100 devices and it seems to have zero issues with that.


#44

@a4refilpad ahhh, then thats why its working for you and you are not seeing the time out for a large number of devices.


(Kevin) #46

I just released version 2.3.1 which should fix the problem with the "All Devices - States" screen and make it more useful by only showing values for the devices that have the corresponding capabilities.

Although it can be frustrating at times, I do appreciate when users push issues because the end result is sometimes a better SmartApp, so thank you.

When you have a moment, can you update to version 2.3.1 and let me know if the "All - Device States" screen loads for you? It seems to work fine with my 81 devices and all capabilities selected, but I'm curious to know if it will still load with 100+ devices.


#47

@krlaframboise 2.3.1 seems to have fixed "All Devices - States" for me! Thank You!