SmartThings IDE Inaccessable

For the past five days, I have tried to log into and my password is rejected. I can log into and the classic mobile app with the same password with no issues. I have tried different browsers (Firefox, Chrome) and different computers. I have changed my password three times and still I can log in just fine to the mobile app or but always tells me my password is wrong. I am at the end of my rope. Samsung tech support just wants screen shots of my login failures. Is anyone else having this problem?

Are you selecting the “SIGN IN WITH SAMSUNG ACCOUNT” option?

Yes, I have been using that option since the account transition from the “smartthings account” quite awhile back. Less than a week ago, my Samsung account can suddenly get to everything Samsung with the exception of the IDE. I have Smartapps that need updating and devices I need to change. Without access, I am contemplating ripping my over 200 Zwave/Zigbee devices out and using something else.

Try using the universal address for the IDE instead of graph.api.

Your new Samsung account might be on a different shard in the SmartThings cloud. The universal URL automatically direct you to the correct shard.

If that doesn’t work, you may need to contact support.

@JDRoberts, Thanks you, thank you! You are my hero. Despite the fact that is still ultimately the website at which you connect to the IDE, it was ABSOLUTELY critical to log into in order to have my username recognized. This has NEVER been an issue before. Apparently something changed in the last 7 days. I never saw any notes regarding this. I’ve changed my web bookmarks from to the new and everything is now working. Thank you again, you are my hero. I got into the IDE and updated my Smartapps and fixed the devices I was having problems with. Wow, just wow.


wait! yesterday you said didn’t work

It turns out that my VPN connection was also playing havoc with the login for some reason. Yesterday when I tried my VPN connection was on and today it was off and worked. Still, and noteworthy, graph.api no longer works. When it rains, it pours.

1 Like