SmartThings Dimmer Modules can't be turned off/on by Alexa Echo

I bought my SmartThings Hub in July 2017. It replaced an X10 System I co-designed in 1984 which ran 33 years non-stop with about 20 devices. One of the first ST modules I bought two years ago was the only ST dimmer I could find: Leviton DZPD3. I used that module for 2 years to control my Lining Room Lamp. Like my X10 I wanted to light the lamp early evening, dim it to nightlight brightness at 11:30 PM, turn it off in the morning.
The module had some surprises (AKA weird Quirks). The module dimmed to 10% is not nearly as dim as a nightlight. ST can turn it on off normally until your first DIM. After that ON goes to the last DIM the module was at. After some thought I had a workaround, for an ON Routine I DIM to 100%. A daily sequence is DIM 100%, DIM 10%, OFF. I lived with that.
Recently I was given an ALEXA - actually an ECHO with wakeup word of ALEXA. I was stunned when I found ALEXA (which works with my other 21 ST modules) says, “Living Room doesn’t support that.”
I decided it has been 2 years, and now many dimmer modules exist. I bought a Honeywell 39336 which lists SmartThings right on the box. I figured all three quirks could be resolved by now. Imagine my shock to find both brands have all 3 quirks including, “Doesn’t Support That”.

Am I doing something wrong? Is there another brand dimmer module that will work with ALEXA via ST?

Leo Taylor

I’m guessing this is more of an Alexa getting confused case than ST not supporting it. if you go to the device in the Alexa app, does it have a slider at the bottom for adjusting the brightness?


Thank you for being my “First Responder”.

I only used the Alexa APP once to install my Echo. I never knew it had an interface for controlling the ST devices. I assumed Alexa just just converted voice to commands to be forwarded to ST

This was an Epiphany! Thank You. You taught me there is a user interface in Alexa I was unaware of.

I found devices divided in two groups PLUGS and SWITCHES. It has not been supervised and had some obsolete devices that were deleted from ST awhile back. Some devices are in there twice, one with a Red Dot as unresponsive. I “cleaned up” Alexa’s vision of my devices by deleting all red dot devices except Holiday Lights (seasonal) and one of two Living Room that said “If you wish to remove…”. The remaining Living Room has a red dot but no suggedtion to remove it.

The Living Room entry has the Power slider you mentioned and it does not work. Tapping for ON says, “Waiting for SmartThings” then returns to off. If I set the slider it pops back to zero.

You may be right that the two brands of Dimmers I used Leviton & Honeywell have an Alexa issue but ultimately the control comes from ST Hub.

Any suggestions of where to go from here?

Thanks Again,


BTW: I do not have any other devices that dim (like bulbs) I can test with Alexa.

I would delete any device with a red dot from Alexa. Then check the Alexa integration inside smartthings to make sure either all devices are allowed or you have the specific device you want added. Then ask Alexa to discover devices again. Also make sure the devices have very unique names in Alexa. if there are some with the word “living room” in them that could also be a problem.



I’m sorry this is turning into an Alexa thread, I use ST often but Alexa only for turning a few things on and off with voice.

We are making progress. I removed the Living Room (a unique name). I looked for Discover on the APP, searched the web, found I could just walk over to the Echo and say Alexa Discover Devices. In a short while it found a device. Went back on the Alexa APP and indeed I now have Living Room without Red Dot. It works from the APP for On, Off, and Power Slider.
Unfortunately voice still says, “Living Room Doesn’t Support That”. Are there different Voice Commands for Dimmer? I’ve been saying, “Alexa Turn On Living Room” just like all my other ST devices.

I searched the Web and found examples of:
Alexa, dim the bathroom light.
Alexa, set the bedroom light to fifty percent.
I tried the both with Living Room and got the usual, “Living Room Doesn’t Support that.”

You have been doing great, we seem to be close.

do you have a room in the Alexa app called “living room”? That could also be an issue since it think you make be trying to dim every device in that room. Try something like “Alexa set living room light to 50%”


I don’t use rooms, locations, groups, or anything like that. Just straight device names. All appear when I logon into for a Device List.

I tried “Alexa set living room light to 50%” and got the usual Doesn’t Support.


@LeoT can you share a screen shot of the device in the Alexa app?

Took me a few minutes. Captured three screens on phone. Transferred to Google Drive. Uploaded to P.C. I’m typing on. Combined into one file.
Could not find ATTACH on Support. I found Link so I plopped it on my website.

Then I found Upload:

Use whichever works for you.


Ah. On that last screen shot, tap where it says “Type plug” and then choose light. Then try again.


OK, I changed Living Room from PLUG to LIGHT. Though most of my devices are lights (non dimmable modules) the LIGHT section was empty. All other devices were in Plugs or Switches. Alexa APP still controls Living Room by tapping, but voice gives Doesn’t Support.

Well, I’m out of ideas. Try giving Amazon support a call. They’re supposedly pretty good.

1 Like

Thank you for getting me this far! As I mentioned, I’m asking Alexa questions on SmartThings Support. I really thought is was STs fault because I did not know the Alexa APP had so much to it.

You did a great Job,

BTW: I retired from Hewlett Packard after 35 years. I did hardware support most of those years. OTOH I went on site most of the time.


Not sure if you tried this…and just a shot in the dark. Try renaming the “Living Room” to something else like “Poker Parlor” and ask Alexa to discover.


Could try renaming it straight in the Alexa app


BINGO! You did it. I renamed Living Room to Poker Parlor and it fixed the problem. There must be remnants of Living Room that were not erased when I removed and re-discovered it. Changing the name in the Alexa APP (no re-discovery needed) solved it.

On and Off work just like SmartThings, once dimmed the ON command goes to last dim (not full power). Two years ago I did a workaround, my ST ON Routine does a DIM of 100%.

I tried the two formats I mentioned I found on the web: Dim the Poker Parlor (goes from dim to 0) and Set Poker Parlor to 50% (works well with several levels I tried).

Mainly I’ll use verbal ON and OFF when I’m sitting in the room.

SmartThings APP and Device List are still using Living Room. I’ll pick a new name and use it everywhere.

Thank You for Everything! This was a cross platform problem I’d have a hard time explaining to Alexa support.



We have several Alexa devices and a ST hub. Our oldest decide is 2 or 3 years old. Everything worked great, until about a month ago, we can’t turn any thing off because “device does not support that”. The only work around I have found is anything with a dinner can be set to 0. It’s driving me crazy. Will try to rename things and see if it helps.

I can’t believe it was as simple as that. After I changed the names, I was able to go back to the original names so it didn’t mess with my routines.

Typically when I’m having an issue with Alexa and SmartThings, it’s because of a naming issue.

You could try deleting a device in the Alexa App and then run discovery front an Alexa device or Alexa App. Make sure the device type is set correct in the Alexa App and make sure the devices you want to control from the Alexa device is checked in the “Alexa App” in “SmartThings“.

If all else fails, then just start over by removing the Alexa App from SmartThings and go through the setup process again.