Smartthings dev's please stop breaking things

I have some edge driver smart plugs and the value’s in watts that are recorded are jumping up and down. One time, they record for example 100w. Then 100mW, then 100kwh.
The range simply changes, while the edge driver did NOT change. Whats going on?

Hi, @goosetapo
Could you provide more details, please?

How are you sending the capability event, are you including the unit there as well?
Have you checked the events sent in the driver’s logcat to compare the values shown in the history?

perhaps @Mariano_Colmenarejo can provide some insight, i’m using his drivers. I know that no changes were made by either me and him, and yet, wattage values are changing seemingly randomly.

Hi @nayelyz

The driver emits the events with the units the same as the default handler

device:emit_event_for_endpoint(zb_rx.address_header.src_endpoint.value, capabilities.powerMeter.power({value = raw_value_watts, unit = "W" }))

device:emit_event_for_endpoint(zb_rx.address_header.src_endpoint.value,{value = raw_value, unit = "kWh" }))

I don’t know the values that the device sends to the driver.

Thank you for the info about the configuration for the driver, @Mariano_Colmenarejo

@goosetapo, we still need the driver logs in your case for the report, please. For that you need to set up the ST CLI](Get Started With the SmartThings CLI | SmartThings Developers) and run the following command:

smartthings edge:drivers:logcat

Copy the results into a file and share it with us, please. I don’t know how often the device makes the reports but you need to make sure that the powerMeter and energyMeter events are included in the file.

Also, provide access to your account and share the name of the device with the issue, please:

  1. Confirm the email account registered in the forum is the same one you use for SmartThings. If not, please share it with me over DM
  2. Enable support access to your account:
  1. Go to the SmartThings Web (
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

i currently fixed the issue by completely cutting it for power(over 10 seconds) and reconnecting it. hopefully it stays the same. if not i will take these steps and inform you.