SmartThings developer mode not working

Since the last SmartThings update a few days ago I have been unable to enter developer mode in the app on mobile. I have tried on both IPhone and Android. Did something change? Is it still valid to long press on ‘About SmartThings’ to enter developer mode?

@nayelyz … I am also seeing the same issue. Please help.

Hi, @ph007, @Craig_DuBois

I just checked on Android and I was able to enable it using version of the app.
However, in iOS I couldn’t enable it either, I’m checking with the engineering team to see if they know something about that.
In the meantime, please double-check in Android, it might take more than 5 seconds to appear, so hold the button a little bit longer.

Also, you can try clearing the app’s cache on Android to force a refresh of the app. This can be done by following these steps:

  1. In your mobile device, go to settings
  2. Find the option to manage the apps (where you can configure the data usage, notifications, etc.)
  3. Look for the SmartThings app and enter its configuration
  4. Go to the option “storage” and click on “Clear cache”

Great, Thank you Nayelyz. I was able to get it to work on Android, it definitely didn’t for a day or two after the update and then magically started working again. IPhone is still a no go though.

Thank you for the confirmation, @Craig_DuBois

The team is already looking into my report about the iOS app, I’ll let you know once we get their feedback.

On Android (13) I’m able to get the development toggle - but when I’m trying to toggle it, there seem to be an issue with File And Media permission - although I gave the app all the permissions possible, it won’t switch to development mode. Am I missing something?

Hi, @RonaldvM
Can you share the following info to, please?

  1. A screen recording of the issue with the permissions when you try to enable the developer mode.
  2. The Android mobile app logs. There are two ways of getting them depending on your mobile device

Option 1

  1. On your mobile device, launch the Phone app (where you make calls) and enter the code *#9900#
  2. On the opened page, click on “Run Dumstate/Logcat”. Wait until it finishes and shows a message with the created file
  3. Then, select the option “Copy to SD card (Include cp Ramdump)”. When it finishes, it will show a success message.
  4. Share the file with us, please. There are two options:
    From your phone:
  5. Go to Files > internal storage
  6. Find a folder called “log” and search the created file there. Sample name: “dumpState_G950USQU8DUD3_202208162013”
    The last part helps you identify it better because it includes the date and time when it was generated.
    From a PC. Connect your device to a PC and look for the “log” directory and find the generated file.

Option 2

For other Android devices:
1- Mobile Device Logs | Android Device Logs: Prerequisites - YouTube
2- Mobile Device Logs | Android Device Logs: Windows - YouTube
3- Mobile Device Logs | Android Studio - YouTube

Is exactly what’s happening for me. This is the case on my s22+ AND brand new a8 tab.

Also unable to activate developer mode. App prompts to add “Files and media” permissions but they’re not available to be added. S22

Same here. S23 ultra. App is asking for Files and Media permissons but they’re not available.

Hi, @Nickynick, @Dbohling, @tmill

Could any of you share the info I requested above, please?

Having the same issue here on iOS. This an extremely critical issue for our team, we need to enable developer mode to deploy our custom integration.

Hi @nayelyz,

I’ve just sent the requested files.
Hoping this issue get resolved soon

Facing the same issue on a Xiaomi device running Android 13.

Hello - any updates on this?

Hi, @Justin_M
No, there are no updates yet, once we have more info, we’ll let you know here.

Any news? A way to override?

I believe it was fixed in the last IOS patch. I tried it on my IPhone on Friday and was able to get into developer mode.

Still not working on Android.

Hi, @Tomer_Fernandes. I already asked the team about that, as @Craig_DuBois mentioned, it is solved on iOS.

Unfortunately, there is no workaround on the same Android 13, previous versions don’t have this issue.