Smartthings api doesn't see my hub


(Mike Kelley) #1

So an in effort to fix the Ecolink motion sensor issue that everyone has, I am trying to login to the API and change the device manually – except it says I have no hub and need to claim it from the app (which obviously does see my hub).

So – not to be impolite but WTF? I only have one account, and it doesn’t see it, so anyone have a clue as to how to remedy this?


#2

I’ve been having a similar issue here. I found going to the “My Location” tab, and then back to the hubs and devices page would let them magically show up again.

Its made for a frustrating time setting up all my equipment for the first time, as sometimes I’ll click on the devices tab, and it will say that there is nothing there all of a sudden.


(Mike Kelley) #3

That did it – thanks so much!

(For something called SmartThings it’s amazing how dumb it is most times).


#4

Thanks, this helped me too!


(Larry Hanson) #5

This still seems to be a problem, at least for my account. The steps above worked around the problem, but it should work by default in my opinion.

If I come in straight to ide.smartthings.com I get no hubs in the “My Hubs” tab, and no locations when selecting “Simulator” in the IDE while editing a newly created script. But if I navigate via the “My Locations” tab, my location shows up in the “Simulator”, and then so does my hub via “My Hub” tab.

Also, oddly, the script I created in the other context is now no longer listed, and I had to start from scratch. Looks like all y’all still need to sort out your shard (non)solution.


(Srikanth) #6

Awesome, Thank you very much, I helped me


(Cristian) #7

That didn’t solve problem. I still can’t see my hub :confused:


(Greg Guinther) #8

I would like to use the SmartThings API but I can’t figure out how to make it see my hub. It shows up on the app. I tried the visit your “Locations” tab suggestions but no luck.


(Turbopowered) #9

went to my locations on the API and then back and this worked for me as well! Cheers thanks for the help for a new user trying to make this work!


(Jim Farrell) #10

Jeez. I should be so lucky as everyone else. My wife set up our hub, then “invited” me as a user. Now I’m trying to add a RBoy app and am having no luck. Clearly our hub is working, as we’ve connected multiple devices and the iOS app works fine. Yet there are no locations, hubs, device handlers or locations showing. Even when I tab back and forth as suggested above.

Could this be due to my not being the “primary” account holder, i.e. the person who originally set up the hub? I need to try and figure this out “remotely” as the home we set it up in is 500 miles away in Charleston!

Thanks in advance for any help.