SmartThings API Browser+ ... Now Available to All

been there done that,I have used the stock drivers, Mariano’s driver and philh30. makes no difference. it seems like devices that i paired and then changed the drivers.

I was able to change a few of my Ge switches from the stock Zwave switch edge driver to the philh30 driver and they changed from NONFUNCTIONAL to PROVISONED. So Im guessing it has something to do with the driver. I have several Aeotec Multisensor 6 devices that I paired with the driver created by Aeotec and they show NONFUNCTIONAL?

@TAustin Do you know what the difference is between NONFUNCTIONAL and PROVISONED is in the API?

I certainly don’t, but the other two possibilities for the provisioning state for ‘widget devices’ (whatever that means) are TYPED and DRIVER_SWITCH if that helps anyone join the dots.

I checked all of these sensors now and 2 of them show PROVISIONED and 2 show NONFUNCTIONAL thier all using the same driver? I wouldn’t really care but i’m trying to figure out why some of my routines no longer work now that thier local and they worked fine in the cloud. I’m thinking it is one of the devices with a bad driver. NONFUNCTIONAL dosen’t sound good to me and I have searched the forum for it but didnt see anything pointing to what this means.

Hi, Thank you for this thread with the new drivers. I was hopeful that it would solve my issue.

I have Zen21 that I can setup a routine. It saves and establishes a routine under automation but then when I come back to check or edit the routine it is not showing under the switch but still showing on the automation page.

I also can’t turn off the LED anymore.

Anyone else seeing this?

Hi @TAustin
would it be posible to add the ability to alter rules
Thanks martin

1 Like

Yes sir. I’ll try to have it added in my next update.


thank you

@TAustin is is there anyway to filter by key value so I can see all devices with the same fingerprint or in the same room or local execution Etc?

Feature request @TAustin . Would it be possible to make the buttons have an on/off state so I can just click on another device and see its details, for example. Many thanks.


absolutely LOVE this tool. So great for seeing what devices are still using DTH and which are already Edge. However, when I try to change an Edge driver for one of my devices, I always get the following error: “Driver change failed with HTTP error 400”

Any clue why that might be happening?


I can look at adding additional filters.

Usually this is from trying to move a device to a driver that doesn’t support its fingerprint.

Thank you.

Hmmm. I’m trying to change an Aeotec Door Window sensor from the generic Z-Wave driver to the dedicated driver supplied by Aeotec, so it should support it.

In fact I’m always getting that error when trying to change drivers. Also happens across different browsers…

Can you successfully change the driver in the app?

Bizarrely, it is now working. Not sure if Aeotec updated the drivers or if it was just a glitch in the matrix.

Thanks for your help!!


Dumb question? How do I get the SmartThings Personal Access Token?

OK. Forget this query, I figured it out from other posts. Thanks.

There is any virtual device that can be used to trigger routines in Alexa? I tried with button and switches virtual devices but I cannot select them as the trigger for a routine in the Alexa app.