SmartThings API Browser+ ... Now Available to All

Can you successfully change the driver in the app?

Bizarrely, it is now working. Not sure if Aeotec updated the drivers or if it was just a glitch in the matrix.

Thanks for your help!!


Dumb question? How do I get the SmartThings Personal Access Token?

OK. Forget this query, I figured it out from other posts. Thanks.

There is any virtual device that can be used to trigger routines in Alexa? I tried with button and switches virtual devices but I cannot select them as the trigger for a routine in the Alexa app.

I answer myself: vEdge @TAustin amazing Edge driver works like a charm: [ST Edge] vEdge Creator: a virtual device generator for end users


On the API browser you can create a few Virtual cloud switches, with limitations, but I would use the vEdge driver.

1 Like

Just curious: yesterday, many people reported that their routines were no longer being listed in their app

Cannot edit routines/Missing Routines (18 Jan 2023)

And at the same time, some developers said that the CLI was no longer returning a list of their rules.

[Smartthings Cli] Unable to get rules - #3 by JDRoberts

Was API + similarly affected?


The switches created through API plus cannot trigger Alexa routines. But the virtual lock created through API plus CAN be used to trigger Alexa routines.

That’s the only workaround right now for people who don’t have a hub, but need a virtual device that can trigger an Alexa routine.

So definitely, if you do have a hub, one of the edge drivers will be a better solution. But if you don’t, at least there is a way to make it work with just API plus.

In fact, many people are using two virtual devices created through API + : a virtual lock, which can be used to trigger the Alexa routine, and a simple virtual switch which can be used in a SmartThings routine to lock/unlock the virtual lock. Just because the switch is a more natural UI for the person to use. so you end up with two virtual devices, two smartthings routines to tie those devices together, and then your Alexa routine. Clunky, but it works even if you don’t have a smartthings/Aeotec hub. :partying_face:


1 Like

And depending on the use you have if you put it on the favourites screen it serves as a visual indicator or even a push button. Quite useful.
But agreed, the vEdge switches, buttons etc are by far the best if you have a hub.

1 Like

Yes automations/rules cannot be viewed currently. Automations/scenes are still there.

Update. 19.59 GMT. I created a new token to be sure. Still no rules showing.

1 Like

Mine just reappeared!

1 Like


Looks like your tunnel IP address may have changed as the API Browser doesn’t load at the moment. Getting error:


Tunnel not found

All working for me.

Hmm…more investigation required I guess.

Odd, when I discovered I could not delete a rule via the cli (I later figured out adding the PAT would allow that) I deleted the rule via the API Browser+. I never lost access to rules there. I figured it was because i was using the same PAT to access API+ as I used to publish them.

everything works fine here.

1 Like

Yeah, working now. Turns out my work VPN was messing with it for some reason.


Hello, this sounds useful.
I am interested in using this interface.


1 Like

hi @TAustin in Installed drivers is it posible to list how many devices are using specific drivers ie

= 4 devices. and perhaps the abilty to delete/remove unused drivers from there.