Smartthings Android app 1.7.83.21 (March 22)

There may be changes but cant see anything obvious

That’s a bit disappointing. I shall blame the upgrade for my app basically being unusable all morning. It was like it had no network connectivity and was silent failing.

As I am only just installing the update this is, of course, likely to be unfair.

1 Like

Oh no, here we go again…

I find it disappointing that there are never any app UI enhancements or improvements, there is so much that could be done.
Each month the update is small and the app continues to be lacking.
Even the Tuya app is now better than STs app with an excellent weather tile and impressive details among other things

3 Likes

Well so far I’ve not seen any visual changes. At least they didn’t hose up mobile presence. They still did not fix issues with automations and scenes using a Celsius scale when the location is in Fahrenheit and the device reports everything in “F”.

does this fix the presence issue from the previous version?

It was fixed in release 1.7.82.23. When I updated to that version on both my phones worked just fine.

1 Like

Maybe this was part of the Android release? Dated 3/14 in the iOS app notes

Yup, very likely. I just saw that new notice icon indicator in the app.

I dont have that notice, all i ever get is a notice to
CONNECT YOUR SMART METER

and then all the unuseable smart apps are thrown onto the life page

Ironic as Smets1 meters are still not adopted in the Uk and the smart apps are completely pointless… i might have mentioned that before :innocent:

Yes, they are obsessed by that. I even get email spam about it. As they’ve known since day one that I get an error when I try to install the Chameleon ‘device’, this does get a bit wearing.

I’d like them to get that useless crud off the Life page too.

1 Like

Is the listing of components with their parent devices under ‘All devices’ in any way new or just something I’d forgotten about as I rarely use it?

1.7.84.21 for Android now out (Dated April 25, 2022) – nothing in the What’s New is new. Must be just bug fixes. Would be nice to know what was fixed…

The only thing I am noticing is a certain unusual sluggishness in some of the screen updating. For example when going into Settings I get a subliminal glimpse of ‘Home Controller setting’ (or similar) before it disappears and I haven’t had that before. Also I keep catching the driver list reordering in the hub details page. The update might just be a coincidence.

1 Like

I am now finding when looking at the company/device manufacture list, it takes forever to load and sometimes the wait spinning thing just keeps spinning and no manufactures display… no doubt companies who have paid to be on the list would be thrilled to see that happening