Smartthings freezes on Android 13 Pixel 7a

I got a Google Pixel 7a a couple of months ago, installed SmartThings and everything worked. That phone had SmartThings version on it. But the phone had to be replaced. I got a new Google Pixel 7a, same version of Android (13) and transferrred all my apps to the new phone.
But on this new phone, when I open the app for the first time and click on the SignIn link, the app freezes. It also freezes if I click Add Device.
I have uninstalled and reinstalled ST numerous times, restarted the phone, made sure it was at the latest version with all updates, cleared the cache, deleted user data, checked all the permissions the app requested. But no luck.
I called support and was told that ST is only compatible with Samsung devices, which is clearly BS since I have been using it on Android devices for years and currently have it installed on an iPad too. Shame on support for going down that route when it is clearly not the case, but that’s Samsungs response.

Does anyone have any suggestions?


1 Like
  • If you had enabled get location from your old phone, login to Advanced Web App and remove the old phone.
  • remove the app, reboot your phone, add app back
  • what is the default browser on the new phone? not sure if that is related

Try it… not sure it will resolve the issues but at least I will not tell you ST is not supported on non-samsung phones :slight_smile:

There is definitely a problem on iOS and Android when using the transfer with ST from old phones to newer ones. Usually see it on iOS where an uninstall/reinstall fixes it.

thanks for the suggestion, but it didn’t work. As a matter of fact, my previous Pixel 7a was not listed in devices, but my pixel 5 was, I removed it, uninstalled the app rebooted the phone reinstalled the app, same behavior.

BTW, it was a Samsung support tech that told me ST was only supported on Samsung devices, But she did offer to set up an appointment for me at a Samsung store 50 miles away and said they would be able to fix it. Right, the Samsung store is going to fix my Google phone. Like that is going to happen.

Any type of blocking software or vpn being used?

No VPN or anything. I’m going to switch to home assistant.

Oh no! I scared off another user :frowning:


Same - Android 13, Pixel 6 (had it working on a Pixel 6 Android 14, had the phone replaced under warranty last week, it’s still not showing me ability to update to Android 14 if 13/14 is an issue).

I had the same problem. It has been going on for ages now and I have tried so many things. I have just read this post and took into account what jkp said about the default browser. I try changing the default browser to Edge and bam, I can sign in. I have changed back to chrome as the default browser and I am still signed in. Hopefully it stays signed in!

Thankyou @jkp for your suggestion, this has been driving crazy for ages!

I hope this can work for others out there.

1 Like