SmartThing Button disconnected from network, now cannot reconnect


(David Barck) #1

I recently purchased one of the new SmartThings buttons for my SmartThings hub and network. After pairing I used the Smart Lighting App to have the Button toggle a Z-Wave plugin outlet on/off. All worked perfectly. The next day I performed a “Repair Z-Wave Network”. After that, I noticed that the Button was now showing as “disconnected”.
I removed the Button from my Hub (I used the “Remove” function in the SmartThings App). Then I used a paperclip to reset the Button and attempted to re-add it (I followed the instructions on the “Set up and connect the SmartThings Button” web page).

The Button is flashing red and green, and is physically close the the hub (about one foot), but the hub cannot find the Button. I tried it using both the classic SmartThings App and the newer App.

Hub Model: STH-ETH-250
Button: IM6001-BTP01

Any suggestions?


(David Barck) #2

I have since tried these actions to solve the problem:

  1. Moved the SmartThings hub away from my network router (I have heard that since Zigby and WiFi both use the 2.4 Ghz radio band, they can interfere with each other )
  2. Rebooted the SmartThings hub (using a paperclip)
  3. Removed the battery from the SmartThings button and then put it back in.

Removing and putting the battery back in solved my issue.


(Bruce Gaskill) #3

I experienced the same issue last week - Device Disconnect Error - Even though the device was still working with Alexa and the SmartThings app. This is how I fixed it.

On the Devices page (link on bottom of app) I selected Edit on the top right then scrolled down to the affected device, changed the Device Card Color then hit Save and the problem was gone. I then changed the Device Card Color back and everything worked fine. I guess just making a simple change, like changing the device card color was all the App needed to removed the Disconnect Error message.