SmartLighting Question

I’m using SmartLighting to set up some motion activated lights (e.g., kitchen) such that when motion is active, the lights turn on, and when motion becomes inactive for 5 minutes, the lights turn back off. Is there a way to deactivate this rule if the switch is manually turned on? Right now, even if I manually turn on the switch, the lights will still turn off 5 minutes after motion becoming inactive.

I realize this could probably be done using RM and boolean, but I’d like to stay with SmartLighting for local control.

This is the only thing putting me off switching my lighting from RM to SmartLighting for the local control. I have a virtual switch for each room, so that I can override my lights responding to motion. I want to have a “Disable Automation if switch on” feature like Rule Machine.

No one wants the lights to turn off, when say your TV is on and you’re sat still, so I’d say this is a very essential feature.

Add it please and I’ll move my rules over to SmartLighting

1 Like

I started to switch my rules from Rule Machine over to Smart Lighting and this app sucks…
I setup a rule to turn on a light at 5:15am. This was a mistake, should be 5:15pm - so I changed it the next day after realizing.

The light still comes on at 5:15am lol I checked and rechecked the rule and the dam thing still comes on in the AM. Rule Machine was everything for me, without it - I’m debating just stopping and redoing everything when Smart Things get their stuff together because this is ridiculous. I have to use like 7 different “smart” apps that Rule Machine did for me. So stupid.

You may be experiencing the same problem I had with Smart Lighting (I can’t remember for sure if I originally set the wrong trigger time like you did, but it’s likely).

After trying a bunch of things (thinking it was some kind of edge case bug with respect to midnight and/or timezones), I ended up deleting and re-creating the automation. Problem solved :grin: